summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorWORLDofPEACE <worldofpeace@protonmail.ch>2020-10-04 03:00:15 -0400
committerWORLDofPEACE <worldofpeace@protonmail.ch>2020-11-10 03:24:36 -0500
commit06bb562f35c3aeb658a4adba423448a69a011135 (patch)
tree9493639b2e08ca97a8eb4ceff085ee50826227a0 /meson.build
parent3747d588ab709724920916ad24135164e16c3d15 (diff)
downloadgdm-06bb562f35c3aeb658a4adba423448a69a011135.tar.gz
build: add meson_post_install.py properly
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build4
1 files changed, 3 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index a729792c..7fb3f030 100644
--- a/meson.build
+++ b/meson.build
@@ -164,7 +164,7 @@ libpam_dep = cc.find_library('pam')
pam_extensions_supported = cc.has_header_symbol('security/pam_appl.h', 'PAM_BINARY_PROMPT')
default_pam_config = get_option('default-pam-config')
-# If requested, try autodetecting from release files (see NetworkManager source)
+# If requested, try autodetecting from release files (see NetworkManager source)
if default_pam_config == 'autodetect'
pam_autodetect_map = {
'/etc/redhat-release': 'redhat',
@@ -274,6 +274,8 @@ if xdmcp_dep.found()
endif
subdir('docs')
+meson.add_install_script('build-aux/meson_post_install.py')
+
if meson.version().version_compare('>= 0.53')
summary({
'datadir': gdm_prefix / get_option('datadir'),