summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorBenjamin Berg <bberg@redhat.com>2020-10-06 18:00:29 +0200
committerBenjamin Berg <benjamin@sipsolutions.net>2020-10-06 16:06:47 +0000
commit9d841d681f3d1c58e3df51a98421257f774cd185 (patch)
treeebd23013ebae8820b1feb2562e53cfedf304ecb1 /meson.build
parent083f54f5aeaa72e0b2ebb8ba176e403751f63232 (diff)
downloadgdm-9d841d681f3d1c58e3df51a98421257f774cd185.tar.gz
meson: Fix default location of runtime configurationbenzea/fix-runtime-confi-location
The meson port changed the runtime configuration location to default to the same location as the default configuration. This however is incorrect, as the runtime configuration should be in the runtime directory. Change the default to be "custom.conf" inside the runtime directory. Fixes: #641
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 7e336bfa..c059a135 100644
--- a/meson.build
+++ b/meson.build
@@ -24,10 +24,10 @@ pam_mod_dir = (get_option('pam-mod-dir') != '')? get_option('pam-mod-dir') : gdm
dbus_sys_dir = (get_option('dbus-sys') != '')? get_option('dbus-sys') : get_option('sysconfdir') / 'dbus-1' / 'system.d'
gdm_defaults_conf = (get_option('defaults-conf') != '')? get_option('defaults-conf') : gdm_prefix / get_option('datadir') / 'gdm' / 'defaults.conf'
gdm_custom_conf = (get_option('custom-conf') != '')? get_option('custom-conf') : gdmconfdir / 'custom.conf'
-gdm_runtime_conf = (get_option('runtime-conf') != '')? get_option('runtime-conf') : gdm_custom_conf
gnome_settings_daemon_dir = (get_option('gnome-settings-daemon-dir') != '')? get_option('gnome-settings-daemon-dir') : gdm_prefix / get_option('libexecdir')
check_accelerated_dir = (get_option('check-accelerated-dir') != '')? get_option('check-accelerated-dir') : gdm_prefix / get_option('libexecdir')
gdm_run_dir = (get_option('run-dir') != '')? get_option('run-dir') : gdm_prefix / get_option('localstatedir') / 'run' / 'gdm'
+gdm_runtime_conf = (get_option('runtime-conf') != '')? get_option('runtime-conf') : gdm_run_dir / 'custom.conf'
gdm_pid_file = (get_option('pid-file') != '')? get_option('pid-file') : gdm_run_dir / 'gdm.pid'
ran_once_marker_dir = (get_option('ran-once-marker-dir') != '')? get_option('ran-once-marker-dir') : gdm_run_dir
working_dir = (get_option('working-dir') != '')? get_option('working-dir') : gdm_prefix / get_option('localstatedir') / 'lib' / 'gdm'