summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorMarco Trevisan (TreviƱo) <mail@3v1n0.net>2020-08-28 13:57:33 +0200
committerRay Strode <halfline@gmail.com>2020-08-31 13:20:26 +0000
commitb01713b96f96642e8a643b5bce116b9efaf4f8ae (patch)
tree5885b1dc84e9bc79c1979dfe9e012c005d61eeaa /meson.build
parentaaf82e9e63112ec01de97d2c2568b2fccf8ccad2 (diff)
downloadgdm-b01713b96f96642e8a643b5bce116b9efaf4f8ae.tar.gz
meson: Don't look for non-existent journald dependency
Systemd journal library is provided by libsystemd, given that such API has more than 8 years, is probably not needed to convert this into a feature and check for a required systemd version in case it's enabled. So, just set ENABLE_SYSTEMD_JOURNAL just reading the option.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build3
1 files changed, 1 insertions, 2 deletions
diff --git a/meson.build b/meson.build
index 2bb3982c..707c3021 100644
--- a/meson.build
+++ b/meson.build
@@ -96,7 +96,6 @@ endif
# systemd
systemd_dep = dependency('systemd')
libsystemd_dep = dependency('libsystemd')
-journald_dep = dependency('journald', required: get_option('systemd-journal'))
if meson.version().version_compare('>= 0.53')
systemd_multiseat_x = find_program('systemd-multi-seat-x',
required: false,
@@ -228,7 +227,7 @@ conf.set('HAVE_KEYUTILS', keyutils_dep.found())
conf.set('SUPPORTS_PAM_EXTENSIONS', pam_extensions_supported)
conf.set('HAVE_SELINUX', libselinux_dep.found())
conf.set('ENABLE_USER_DISPLAY_SERVER', get_option('user-display-server'))
-conf.set('ENABLE_SYSTEMD_JOURNAL', journald_dep.found())
+conf.set('ENABLE_SYSTEMD_JOURNAL', get_option('systemd-journal'))
conf.set('ENABLE_WAYLAND_SUPPORT', get_option('wayland-support'))
conf.set('ENABLE_PROFILING', get_option('profiling'))
conf.set('GDM_INITIAL_VT', get_option('initial-vt'))