summaryrefslogtreecommitdiff
path: root/utils/Makefile.am
diff options
context:
space:
mode:
authorGeorge Lebl <jirka@5z.com>2001-10-24 18:06:22 +0000
committerGeorge Lebl <jirka@src.gnome.org>2001-10-24 18:06:22 +0000
commit04eef84f74899f19fe10aa4d6a19554cfb85b6a3 (patch)
tree202a119e3bc674e3828451b0182acd6f62220afb /utils/Makefile.am
parent5bcf6a5d10f8acd0a210f3b2cdceb2fa582e254f (diff)
downloadgdm-04eef84f74899f19fe10aa4d6a19554cfb85b6a3.tar.gz
add a small utility for safely making temp files
Wed Oct 24 11:02:55 2001 George Lebl <jirka@5z.com> * utils/gdmkstemp.c, utils/Makefile.am: add a small utility for safely making temp files Tue Oct 23 15:17:23 2001 George Lebl <jirka@5z.com>
Diffstat (limited to 'utils/Makefile.am')
-rw-r--r--utils/Makefile.am14
1 files changed, 11 insertions, 3 deletions
diff --git a/utils/Makefile.am b/utils/Makefile.am
index ea97003b..d047fb50 100644
--- a/utils/Makefile.am
+++ b/utils/Makefile.am
@@ -20,9 +20,10 @@ INCLUDES = \
$(GNOME_INCLUDEDIR)
sbin_PROGRAMS = \
- @GDMASKPASS@ \
- @GDMOPEN@
-EXTRA_PROGRAMS = gdmaskpass gdmopen
+ @GDMASKPASS@ \
+ @GDMOPEN@ \
+ gdmmkstemp
+EXTRA_PROGRAMS = gdmaskpass gdmopen gdmmkstemp
gdmaskpass_SOURCES = \
gdmaskpass.c
@@ -30,6 +31,9 @@ gdmaskpass_SOURCES = \
gdmopen_SOURCES = \
gdmopen.c
+gdmmkstemp_SOURCES = \
+ gdmmkstemp.c
+
gdmaskpass_LDADD = \
$(GNOME_LIBDIR) \
$(INTLLIBS) \
@@ -39,3 +43,7 @@ gdmaskpass_LDADD = \
gdmopen_LDADD = \
$(GNOME_LIBDIR) \
$(INTLLIBS)
+
+gdmmkstemp_LDADD = \
+ $(GNOME_LIBDIR) \
+ $(INTLLIBS)