summaryrefslogtreecommitdiff
path: root/config/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'config/Makefile.am')
-rw-r--r--config/Makefile.am65
1 files changed, 41 insertions, 24 deletions
diff --git a/config/Makefile.am b/config/Makefile.am
index f8782143..4179061c 100644
--- a/config/Makefile.am
+++ b/config/Makefile.am
@@ -1,3 +1,5 @@
+NULL =
+
pixmapdir = $(datadir)/pixmaps
confdir = $(gdmconfdir)
gdmlocaledir = $(gdmconfdir)
@@ -11,30 +13,45 @@ predir = $(gdmconfdir)/PreSession
postlogindir = $(gdmconfdir)/PostLogin
# logdir is set by configure.ac
-noinst_DATA = gdm.conf
-
-DESKTOP_FILES = default.desktop @SSHDESKTOP@
-
-EXTRA_DIST = \
- gdm.conf.in \
- gdm.conf-custom.in \
- $(DESKTOP_FILES) \
- default.desktop.in \
- ssh.desktop.in.in \
- Xsession.in \
- gdm \
- gdm-autologin \
- locale.alias \
- Init.in \
- PreSession.in \
- PostSession.in \
- PostLogin \
- XKeepsCrashing \
- gettextfoo.h \
- gdmprefetchlist.in \
- extract-shell.sh
-
-CLEANFILES = Xsession gdm.conf gdm.conf-custom default.desktop ssh.desktop Init PreSession PostSession gdmprefetchlist
+noinst_DATA = \
+ gdm.conf \
+ $(NULL)
+
+DESKTOP_FILES = \
+ default.desktop \
+ $(NULL)
+
+EXTRA_DIST = \
+ gdm.conf.in \
+ gdm.conf-custom.in \
+ $(DESKTOP_FILES) \
+ default.desktop.in \
+ ssh.desktop.in.in \
+ Xsession.in \
+ gdm \
+ gdm-autologin \
+ locale.alias \
+ Init.in \
+ PreSession.in \
+ PostSession.in \
+ PostLogin \
+ XKeepsCrashing \
+ gettextfoo.h \
+ gdmprefetchlist.in \
+ extract-shell.sh \
+ $(NULL)
+
+CLEANFILES = \
+ Xsession \
+ gdm.conf \
+ gdm.conf-custom \
+ default.desktop \
+ ssh.desktop \
+ Init \
+ PreSession \
+ PostSession \
+ gdmprefetchlist \
+ $(NULL)
Xsession: $(srcdir)/Xsession.in
sed -e 's,[@]XSESSION_SHELL[@],$(XSESSION_SHELL),g' \