summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 10 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 1a25c808..bba96d2b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -254,7 +254,10 @@ AC_ARG_WITH(tcp-wrappers,
[Use TCP Wrappers @<:@default=auto@:>@]),,
with_tcp_wrappers=auto)
-
+AC_ARG_WITH([udevdir],
+ AS_HELP_STRING([--with-udevdir=DIR],
+ [Directory for udev files]),
+ [with_udevdir=$withval], [with_udevdir=$($PKG_CONFIG --variable=udevdir udev)])
AC_ARG_WITH([systemdsystemunitdir],
AS_HELP_STRING([--with-systemdsystemunitdir=DIR],
[Directory for systemd service files]),
@@ -867,6 +870,11 @@ AC_PATH_PROG(SYSTEMD_X_SERVER, systemd-multi-seat-x, [/lib/systemd/systemd-multi
AC_SUBST(SYSTEMD_X_SERVER)
AC_DEFINE_UNQUOTED(SYSTEMD_X_SERVER,"$SYSTEMD_X_SERVER",[Path to systemd X server wrapper])
+if test "x$with_udevdir" != xno; then
+ AC_SUBST(UDEV_DIR, [$with_udevdir])
+fi
+AM_CONDITIONAL(INSTALL_UDEV_RULES, test x$with_udevdir != xno)
+
if test "x$with_systemdsystemunitdir" != xno; then
AC_SUBST(SYSTEMD_SYSTEM_UNIT_DIR, [$with_systemdsystemunitdir])
fi
@@ -1517,6 +1525,7 @@ echo \
XDMCP support: ${XDMCP_SUPPORT}
SELinux support: ${use_selinux}
systemd unit dir: ${with_systemdsystemunitdir}
+ udev dir: ${with_udevdir}
plymouth support: ${use_plymouth}
wayland support: ${enable_wayland_support}
Build with RBAC: ${msg_rbac_shutdown}