summaryrefslogtreecommitdiff
path: root/daemon/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'daemon/Makefile.am')
-rw-r--r--daemon/Makefile.am12
1 files changed, 12 insertions, 0 deletions
diff --git a/daemon/Makefile.am b/daemon/Makefile.am
index 05810f61..93b18cf2 100644
--- a/daemon/Makefile.am
+++ b/daemon/Makefile.am
@@ -244,10 +244,22 @@ gdm_xdmcp_chooser_slave_LDADD = \
gdm_session_worker_SOURCES = \
session-worker-main.c \
+ gdm-session-auditor.h \
+ gdm-session-auditor.c \
gdm-session-worker.h \
gdm-session-worker.c \
$(NULL)
+if HAVE_LIBAUDIT
+gdm_session_worker_SOURCES += gdm-session-linux-auditor.h \
+ gdm-session-linux-auditor.c
+endif
+
+if HAVE_ADT
+gdm_session_worker_SOURCES += gdm-session-solaris-auditor.h \
+ gdm-session-solaris-auditor.c
+endif
+
gdm_session_worker_LDFLAGS = \
$(PAM_LIBS) \
$(NULL)