summaryrefslogtreecommitdiff
path: root/data/autostart/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'data/autostart/Makefile.am')
-rw-r--r--data/autostart/Makefile.am13
1 files changed, 12 insertions, 1 deletions
diff --git a/data/autostart/Makefile.am b/data/autostart/Makefile.am
index ab7bcd9d..d6696b53 100644
--- a/data/autostart/Makefile.am
+++ b/data/autostart/Makefile.am
@@ -1,14 +1,25 @@
NULL =
+%.desktop: %.desktop.in Makefile
+ $(AM_V_GEN) sed -e 's|@LIBEXECDIR[@]|$(libexecdir)|g' $< >$@
+
desktopdir = $(pkgdatadir)/greeter/autostart
+desktop_in_files = \
+ caribou-autostart.desktop.in \
+ $(NULL)
desktop_DATA = orca-autostart.desktop \
- caribou-autostart.desktop \
+ $(desktop_in_files:.desktop.in=.desktop) \
$(NULL)
EXTRA_DIST = \
+ $(desktop_in_files) \
$(desktop_DATA) \
$(NULL)
+DISTCLEANFILES = \
+ $(desktop_in_files:.desktop.in=.desktop) \
+ $(NULL)
+
MAINTAINERCLEANFILES = \
*~ \
Makefile.in