summaryrefslogtreecommitdiff
path: root/pam_gdm/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'pam_gdm/Makefile.am')
-rw-r--r--pam_gdm/Makefile.am37
1 files changed, 37 insertions, 0 deletions
diff --git a/pam_gdm/Makefile.am b/pam_gdm/Makefile.am
new file mode 100644
index 00000000..5ea69d78
--- /dev/null
+++ b/pam_gdm/Makefile.am
@@ -0,0 +1,37 @@
+END_OF_LIST =
+
+AM_CPPFLAGS = \
+ -I$(srcdir) \
+ -I$(builddir) \
+ -I$(top_srcdir) \
+ -I$(top_builddir) \
+ -DG_LOG_DOMAIN=\"Gdm\" \
+ -DDMCONFDIR=\""$(dmconfdir)"\" \
+ -DDATADIR=\""$(datadir)"\" \
+ $(END_OF_LIST)
+
+pam_gdm_la_SOURCES = \
+ pam_gdm.c \
+ $(END_OF_LIST)
+
+pam_gdm_la_CFLAGS = \
+ $(PAM_CFLAGS) \
+ $(END_OF_LIST)
+
+pam_gdm_la_LDFLAGS = \
+ -module \
+ -export-dynamic \
+ -avoid-version \
+ -shared \
+ $(END_OF_LIST)
+
+pam_gdm_la_LIBADD = \
+ $(PAM_LIBS) \
+ $(END_OF_LIST)
+
+
+pam_gdm_LTLIBRARIES = \
+ pam_gdm.la \
+ $(END_OF_LIST)
+
+pam_gdmdir = $(libdir)/security