summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorDisch, Simon <simon_disch@mentor.com>2016-08-26 16:14:07 +0200
committerDisch, Simon <simon_disch@mentor.com>2016-08-26 16:14:07 +0200
commit8c373435098b67772167b4c80e2c99c67dd16dce (patch)
treee0b07c3572fd5a74a35f8503b841d028f9a9e41d /CMakeLists.txt
parent534894b27a5e6b86cf8d2bd7b53d55d04f2a1bcc (diff)
downloadgenivi-common-api-runtime-8c373435098b67772167b4c80e2c99c67dd16dce.tar.gz
CommonAPI 3.1.93.1.9
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 3 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index b62a926..767f54b 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -10,7 +10,7 @@ PROJECT(libcommonapi)
# version of CommonAPI
SET( LIBCOMMONAPI_MAJOR_VERSION 3 )
SET( LIBCOMMONAPI_MINOR_VERSION 1 )
-SET( LIBCOMMONAPI_PATCH_VERSION 8 )
+SET( LIBCOMMONAPI_PATCH_VERSION 9 )
message(STATUS "Project name: ${PROJECT_NAME}")
@@ -121,6 +121,7 @@ link_directories(
)
file(GLOB CAPI_SRCS "src/CommonAPI/*.cpp")
+list(SORT CAPI_SRCS)
add_library(CommonAPI SHARED ${CAPI_SRCS})
target_link_libraries(CommonAPI PRIVATE ${DL_LIBRARY} ${DLT_LIBRARIES})
set_target_properties(CommonAPI PROPERTIES VERSION ${LIBCOMMONAPI_MAJOR_VERSION}.${LIBCOMMONAPI_MINOR_VERSION}.${LIBCOMMONAPI_PATCH_VERSION} SOVERSION ${LIBCOMMONAPI_MAJOR_VERSION}.${LIBCOMMONAPI_MINOR_VERSION}.${LIBCOMMONAPI_PATCH_VERSION} LINKER_LANGUAGE C)
@@ -136,6 +137,7 @@ CONFIGURE_FILE(commonapi.spec.in commonapi.spec)
# for installation of CommonAPI header files
file (GLOB_RECURSE CommonAPI_INCLUDE_INSTALL_FILES "include/CommonAPI/*.hpp")
+list (SORT CommonAPI_INCLUDE_INSTALL_FILES)
set_target_properties (CommonAPI PROPERTIES PUBLIC_HEADER "${CommonAPI_INCLUDE_INSTALL_FILES}")
# install CommonAPI library including headers