summaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorasanoaozora <fifitaneki@hotmail.com>2017-06-27 18:00:31 +0200
committerasanoaozora <fifitaneki@hotmail.com>2017-06-27 18:00:31 +0200
commit2991b5786fcaf5c62c853e9ce4f4983131b3e17c (patch)
tree1518aa8877c586a3cfab16c274c88df34a8e9cfc /src/CMakeLists.txt
parent902680d117dca3301f94b632cada046a6f56d0e6 (diff)
downloadnavigation-2991b5786fcaf5c62c853e9ce4f4983131b3e17c.tar.gz
add DLT to FSA, align with latest AMB
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt10
1 files changed, 9 insertions, 1 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index c8d3643..b2bec7d 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -17,6 +17,7 @@
###########################################################################
project(fuel-stop-advisor)
cmake_minimum_required(VERSION 2.8)
+find_package(PkgConfig)
option(WITH_DEBUG
"Enable the debug messages" OFF)
@@ -61,7 +62,7 @@ if(NOT EXISTS ${AUTOMOTIVE_MESSAGE_BROKER_DIR})
ExternalProject_Add(${AUTOMOTIVE_MESSAGE_BROKER}
PREFIX ${AUTOMOTIVE_MESSAGE_BROKER_DIR}
GIT_REPOSITORY https://github.com/otcshare/automotive-message-broker.git
- GIT_TAG c216955d16ca275159891cad296217094d972390
+ GIT_TAG 8af1cc9a502cb85736b7afb37dc9073a168aa605
UPDATE_COMMAND ""
PATCH_COMMAND ""
INSTALL_COMMAND sudo make install
@@ -79,6 +80,13 @@ if(NOT EXISTS ${AUTOMOTIVE_MESSAGE_BROKER_DIR})
endif()
endif()
+if(${WITH_DLT})
+ add_definitions("-DDLT_ENABLED=1")
+ pkg_check_modules(DLT REQUIRED automotive-dlt)
+ include_directories( ${DLT_INCLUDE_DIRS} )
+ set(LIBRARIES ${LIBRARIES} ${DLT_LIBRARIES})
+endif()
+
add_subdirectory(navigation/src/navigation "${CMAKE_CURRENT_BINARY_DIR}/navigation")
set(DBUS_GENERATED_INCLUDE_DIR "${CMAKE_CURRENT_BINARY_DIR}/navigation/dbus-include")