summaryrefslogtreecommitdiff
path: root/test/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'test/Makefile.am')
-rw-r--r--test/Makefile.am17
1 files changed, 17 insertions, 0 deletions
diff --git a/test/Makefile.am b/test/Makefile.am
new file mode 100644
index 0000000..72fb8d7
--- /dev/null
+++ b/test/Makefile.am
@@ -0,0 +1,17 @@
+AUTOMAKE_OPTIONS = foreign
+
+if DEBUG
+AM_CFLAGS =$(DEPS_CFLAGS) $(CHECK_CFLAGS) -g
+else
+AM_CFLAGS = $(DEPS_CFLAGS) $(CHECK_CFLAGS)
+#AM_CFLAGS = -fprofile-arcs -ftest-coverage $(DEPS_CFLAGS) $(CHECK_CFLAGS)
+
+endif
+
+noinst_PROGRAMS = persistence_common_object_test
+
+persistence_common_object_test_SOURCES = persistence_common_object_test.c
+persistence_common_object_test_LDADD = $(DLT_LIBS) $(DEPS_LIBS) $(CHECK_LIBS)\
+ $(top_srcdir)/src/libpers_common.la
+
+TESTS=persistence_common_object_test