summaryrefslogtreecommitdiff
path: root/api/franca/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'api/franca/CMakeLists.txt')
-rw-r--r--api/franca/CMakeLists.txt24
1 files changed, 8 insertions, 16 deletions
diff --git a/api/franca/CMakeLists.txt b/api/franca/CMakeLists.txt
index 51fbac0..7f031e4 100644
--- a/api/franca/CMakeLists.txt
+++ b/api/franca/CMakeLists.txt
@@ -24,10 +24,14 @@ cmake_minimum_required (VERSION 2.8.1)
project(whole-franca)
-option(COMMONAPI_TOOL_DIR
- "Absolute path to CommonAPI tool" "")
-option(COMMONAPI_DBUS_TOOL_DIR
- "Absolute path to CommonAPI-DBus tool" "")
+option(COMMONAPI_TOOL_GENERATOR
+ "Absolute path to CommonAPI code generator" "")
+option(COMMONAPI_DBUS_TOOL_GENERATOR
+ "Absolute path to CommonAPI-DBus code generator" "")
+option(COMMONAPI_WAMP_TOOL_GENERATOR
+ "Absolute path to CommonAPI-Wamp code generator" "")
+option(WITH_WAMP_GENERATION
+ "Generate Wamp files" OFF)
get_directory_property(hasParent PARENT_DIRECTORY)
@@ -37,17 +41,5 @@ else()
set(COMMONAPI_GEN_DIR "${CMAKE_CURRENT_BINARY_DIR}/src-gen")
endif()
-if (COMMONAPI_TOOL_DIR)
- message(STATUS "COMMONAPI_TOOL_DIR ${COMMONAPI_TOOL_DIR}")
-else ()
- message (FATAL_ERROR "Set the variable -DCOMMONAPI_TOOL_DIR=<path>")
-endif ()
-
-if (COMMONAPI_DBUS_TOOL_DIR)
- message(STATUS "COMMONAPI_DBUS_TOOL_DIR ${COMMONAPI_DBUS_TOOL_DIR}")
-else ()
- message (FATAL_ERROR "Set the variable -DCOMMONAPI_DBUS_TOOL_DIR=<path>")
-endif ()
-
add_subdirectory(hmi)
add_subdirectory(navigation)