summaryrefslogtreecommitdiff
path: root/api/franca/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'api/franca/CMakeLists.txt')
-rw-r--r--api/franca/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/api/franca/CMakeLists.txt b/api/franca/CMakeLists.txt
index ee3c795..51fbac0 100644
--- a/api/franca/CMakeLists.txt
+++ b/api/franca/CMakeLists.txt
@@ -32,7 +32,7 @@ option(COMMONAPI_DBUS_TOOL_DIR
get_directory_property(hasParent PARENT_DIRECTORY)
if(hasParent)
- set(COMMONAPI_GEN_DIR "${CMAKE_CURRENT_BINARY_DIR}/src-gen" PARENT_SCOPE)
+ set(COMMONAPI_GEN_DIR "${COMMONAPI_GEN_DIR}" PARENT_SCOPE)
else()
set(COMMONAPI_GEN_DIR "${CMAKE_CURRENT_BINARY_DIR}/src-gen")
endif()