summaryrefslogtreecommitdiff
path: root/api/franca/hmi/speechservice/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'api/franca/hmi/speechservice/CMakeLists.txt')
-rw-r--r--api/franca/hmi/speechservice/CMakeLists.txt8
1 files changed, 8 insertions, 0 deletions
diff --git a/api/franca/hmi/speechservice/CMakeLists.txt b/api/franca/hmi/speechservice/CMakeLists.txt
index fb2dfd5..39dac66 100644
--- a/api/franca/hmi/speechservice/CMakeLists.txt
+++ b/api/franca/hmi/speechservice/CMakeLists.txt
@@ -24,6 +24,14 @@ cmake_minimum_required (VERSION 2.8.1)
project(franca-speechoutput)
+get_directory_property(hasParent PARENT_DIRECTORY)
+
+if(hasParent)
+ set(COMMONAPI_GEN_DIR "${COMMONAPI_GEN_DIR}" PARENT_SCOPE)
+else()
+ set(COMMONAPI_GEN_DIR "${CMAKE_CURRENT_BINARY_DIR}/src-gen")
+endif()
+
option(COMMONAPI_TOOL_DIR
"Absolute path to CommonAPI tool" "")
option(COMMONAPI_DBUS_TOOL_DIR