summaryrefslogtreecommitdiff
path: root/gnss-service/CMakeLists.txt
diff options
context:
space:
mode:
author <philippe colliot>2015-05-21 15:02:24 +0200
committer <philippe colliot>2015-05-21 15:02:24 +0200
commitbf00492981d71fead8c0615fae59b73b03a4fbac (patch)
tree7cd137f334030cafa3ae4dc316177f13ac1218bd /gnss-service/CMakeLists.txt
parente0abeac5db5c58343884ff46111d04846773ef15 (diff)
downloadpositioning-bf00492981d71fead8c0615fae59b73b03a4fbac.tar.gz
Improve the build (thanks to Jonathan Maw) and extend the log replayer
Diffstat (limited to 'gnss-service/CMakeLists.txt')
-rw-r--r--gnss-service/CMakeLists.txt16
1 files changed, 3 insertions, 13 deletions
diff --git a/gnss-service/CMakeLists.txt b/gnss-service/CMakeLists.txt
index 112194a..04d38e4 100644
--- a/gnss-service/CMakeLists.txt
+++ b/gnss-service/CMakeLists.txt
@@ -34,27 +34,17 @@ option(WITH_REPLAYER
option(WITH_TESTS
"Compile test applications" OFF)
-option(WITH_DEBUG
- "Enable the debug messages" OFF)
-
SET(CMAKE_INSTALL_RPATH "")
#SET(CMAKE_BUILD_WITH_INSTALL_RPATH TRUE)
message(STATUS "CMAKE_BINARY_DIR =" ${CMAKE_BINARY_DIR})
-message(STATUS)
-message(STATUS "---------------------------------------------------------")
-
add_subdirectory(src)
message(STATUS "---------------------------------------------------------")
if(WITH_TESTS)
add_subdirectory(test)
-message(STATUS "---------------------------------------------------------")
-
-add_subdirectory(test/compliance-test)
-
-message(STATUS "---------------------------------------------------------")
+ message(STATUS "---------------------------------------------------------")
+ add_subdirectory(test/compliance-test)
+ message(STATUS "---------------------------------------------------------")
endif()
-
-message(STATUS)