summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexander Larsson <alexl@redhat.com>2022-02-23 10:19:20 +0100
committerAlexander Larsson <alexl@redhat.com>2022-03-09 10:43:04 +0100
commit3e90d6b40d3dead231444d652954d617c7985cc6 (patch)
tree2b92783f8b3f96e750db21bf9cc1e083f0242498 /CMakeLists.txt
parent13f9c89ced6ffaeb1faf485152e27e1f40d234cd (diff)
downloadvSomeIP-3e90d6b40d3dead231444d652954d617c7985cc6.tar.gz
Support boost 1.76
This adds support for boost 1.76. For this to work we needed a new version of the boost helpers, because boost 1.76beta1 added this change: https://github.com/boostorg/asio/commit/1c16c45a3d447f685dfa7a9b704d26f10b0f3e29 The introduction of these dummy arguments to the constructor of boost::asio::detail::io_object_impl need to be mirrored in the basic socket helpers.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 4 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 65148a5..645825c 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -164,8 +164,10 @@ else()
endif()
message( STATUS "Using boost version: ${VSOMEIP_BOOST_VERSION}" )
-if (${VSOMEIP_BOOST_VERSION} GREATER 107400)
-message( ERROR "boost version ${VSOMEIP_BOOST_VERSION} is not (yet) supported. Latest supported version is 1.74.0" )
+if (${VSOMEIP_BOOST_VERSION} GREATER 107600)
+message( ERROR "boost version ${VSOMEIP_BOOST_VERSION} is not (yet) supported. Latest supported version is 1.76.0" )
+elseif(${VSOMEIP_BOOST_VERSION} GREATER 107500)
+set(VSOMEIP_BOOST_HELPER implementation/helper/1.76)
elseif(${VSOMEIP_BOOST_VERSION} GREATER 107300)
set(VSOMEIP_BOOST_HELPER implementation/helper/1.74)
elseif(${VSOMEIP_BOOST_VERSION} GREATER 106999)