summaryrefslogtreecommitdiff
path: root/test/unit_tests/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'test/unit_tests/CMakeLists.txt')
-rw-r--r--test/unit_tests/CMakeLists.txt29
1 files changed, 29 insertions, 0 deletions
diff --git a/test/unit_tests/CMakeLists.txt b/test/unit_tests/CMakeLists.txt
new file mode 100644
index 0000000..ed63f6f
--- /dev/null
+++ b/test/unit_tests/CMakeLists.txt
@@ -0,0 +1,29 @@
+# Copyright (C) 2015-2022 Bayerische Motoren Werke Aktiengesellschaft (BMW AG)
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+
+project ("unit_tests_bin" LANGUAGES CXX)
+
+file (GLOB SRCS main.cpp **/*.cpp ../common/utility.cpp)
+
+set(THREADS_PREFER_PTHREAD_FLAG ON)
+
+find_package(Threads REQUIRED)
+find_package(Boost 1.55 COMPONENTS filesystem system REQUIRED)
+
+# ----------------------------------------------------------------------------
+# Executable and libraries to link
+# ----------------------------------------------------------------------------
+add_executable (${PROJECT_NAME} ${SRCS} )
+target_link_libraries (
+ ${PROJECT_NAME}
+ vsomeip3
+ vsomeip3-cfg
+ Threads::Threads
+ ${Boost_LIBRARIES}
+ ${DL_LIBRARY}
+ gtest
+)
+
+add_dependencies(build_unit_tests ${PROJECT_NAME})