summaryrefslogtreecommitdiff
path: root/ivi-layermanagement-examples/simple-weston-client/CMakeLists.txt
diff options
context:
space:
mode:
authorTran Ba Khang(MS/EMC31-XC) <Khang.TranBa@vn.bosch.com>2022-12-07 16:30:17 +0700
committerTran Ba Khang(MS/EMC31-XC) <Khang.TranBa@vn.bosch.com>2023-01-13 10:36:02 +0700
commit4c7d574af5cfba7a06c6d5575ee699ee8381fab8 (patch)
tree8376783a71f5618876bdc6686add3a1ddde25585 /ivi-layermanagement-examples/simple-weston-client/CMakeLists.txt
parent7339a15b20debcc0a3e3e8ac1bc8241da003868b (diff)
downloadwayland-ivi-extension-4c7d574af5cfba7a06c6d5575ee699ee8381fab8.tar.gz
CMakeLists: update libweston to version 8
Update the libweston-8 on ivi-id-agent cmake file. Update the libweston-8-protocols on simple-weston-client cmake file Signed-off-by: Tran Ba Khang(MS/EMC31-XC) <Khang.TranBa@vn.bosch.com>
Diffstat (limited to 'ivi-layermanagement-examples/simple-weston-client/CMakeLists.txt')
-rw-r--r--ivi-layermanagement-examples/simple-weston-client/CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/ivi-layermanagement-examples/simple-weston-client/CMakeLists.txt b/ivi-layermanagement-examples/simple-weston-client/CMakeLists.txt
index 847c9a1..d3bb616 100644
--- a/ivi-layermanagement-examples/simple-weston-client/CMakeLists.txt
+++ b/ivi-layermanagement-examples/simple-weston-client/CMakeLists.txt
@@ -22,14 +22,14 @@ project (simple-weston-client)
find_package(PkgConfig)
pkg_check_modules(WAYLAND_CLIENT wayland-client REQUIRED)
pkg_check_modules(WAYLAND_CURSOR wayland-cursor REQUIRED)
-pkg_check_modules(LIBWESTON_PROTOCOLS libweston-7-protocols QUIET)
+pkg_check_modules(LIBWESTON_PROTOCOLS libweston-8-protocols QUIET)
if(${LIBWESTON_PROTOCOLS_FOUND})
#check for DLT
pkg_check_modules(DLT automotive-dlt QUIET)
#import the pkgdatadir from libweston-protocols pkgconfig file
- execute_process(COMMAND ${PKG_CONFIG_EXECUTABLE} --variable=pkgdatadir libweston-7-protocols
+ execute_process(COMMAND ${PKG_CONFIG_EXECUTABLE} --variable=pkgdatadir libweston-8-protocols
OUTPUT_VARIABLE WestonProtocols_PKGDATADIR)
string(REGEX REPLACE "[\r\n]" "" WestonProtocols_PKGDATADIR "${WestonProtocols_PKGDATADIR}")
SET(LIBWESTON_PROTOCOLS_PKGDATADIR ${WestonProtocols_PKGDATADIR})