summaryrefslogtreecommitdiff
path: root/weston-ivi-shell/CMakeLists.txt
diff options
context:
space:
mode:
authorMathias Fiedler <mathias_fiedler@mentor.com>2017-06-01 10:24:17 +0200
committerMathias Fiedler <mathias_fiedler@mentor.com>2017-06-23 09:37:19 +0200
commit892b744589fe9e7371eb0c0ff33192db1c978b09 (patch)
tree1a127c4a9ac90567ab615e5b9c0f5290af59d78c /weston-ivi-shell/CMakeLists.txt
parent2c945a175e6fd6e20dbba2eb84dd141d179d594c (diff)
downloadwayland-ivi-extension-892b744589fe9e7371eb0c0ff33192db1c978b09.tar.gz
weston-ivi-shell, ilmControl: move bitmap save function from ivi-shell to ilm API
With the change of the ivi-wm screenshot requests the weston-ivi-shell no longer writes bmp files when screenshots are requested. To restore the behavior of having bmp files written through the ilmControl API the ilmControl implementation itself needs to write the bmp files. This commit moves the save_as_bitmap function from the weston-ivi-shell to the ilmControl. Signed-off-by: Mathias Fiedler <mathias_fiedler@mentor.com>
Diffstat (limited to 'weston-ivi-shell/CMakeLists.txt')
-rw-r--r--weston-ivi-shell/CMakeLists.txt1
1 files changed, 0 insertions, 1 deletions
diff --git a/weston-ivi-shell/CMakeLists.txt b/weston-ivi-shell/CMakeLists.txt
index 265e559..7d1123b 100644
--- a/weston-ivi-shell/CMakeLists.txt
+++ b/weston-ivi-shell/CMakeLists.txt
@@ -61,7 +61,6 @@ link_directories(
add_library(${PROJECT_NAME} MODULE
src/ivi-controller.c
- src/bitmap.c
${BUFFER_SHARING_SRC_FILES}
)