summaryrefslogtreecommitdiff
path: root/weston-ivi-shell/CMakeLists.txt
diff options
context:
space:
mode:
authorTimo Lotterbach <timo.lotterbach@bmw-carit.de>2014-01-31 12:31:00 +0100
committerTimo Lotterbach <timo.lotterbach@bmw-carit.de>2014-01-31 13:07:00 +0100
commitc09f77106e85cd48478912443d7e4f53665abb6e (patch)
tree5d2bce043576ee6cca42b7e8ef743640742c29d6 /weston-ivi-shell/CMakeLists.txt
parent67d9e0c6a91967fecb9da9a236c603a0b6ce59c3 (diff)
downloadwayland-ivi-extension-c09f77106e85cd48478912443d7e4f53665abb6e.tar.gz
replaced wayland/weston findmodules with pkgconfig dependency handling
Signed-off-by: Timo Lotterbach <timo.lotterbach@bmw-carit.de>
Diffstat (limited to 'weston-ivi-shell/CMakeLists.txt')
-rw-r--r--weston-ivi-shell/CMakeLists.txt17
1 files changed, 9 insertions, 8 deletions
diff --git a/weston-ivi-shell/CMakeLists.txt b/weston-ivi-shell/CMakeLists.txt
index 63fd35f..e071747 100644
--- a/weston-ivi-shell/CMakeLists.txt
+++ b/weston-ivi-shell/CMakeLists.txt
@@ -22,10 +22,11 @@ cmake_minimum_required (VERSION 2.6)
project(ivi-controller)
project_type(CORE)
-find_package(Cairo REQUIRED)
-find_package(Wayland REQUIRED)
-find_package(Weston REQUIRED)
-find_package(Pixman REQUIRED)
+find_package(PkgConfig REQUIRED)
+pkg_check_modules(WAYLAND_SERVER wayland-server REQUIRED)
+pkg_check_modules(CAIRO cairo REQUIRED)
+pkg_check_modules(WESTON weston REQUIRED)
+pkg_check_modules(PIXMAN pixman-1 REQUIRED)
add_custom_command(
OUTPUT ivi-application-server-protocol.h
@@ -54,10 +55,10 @@ add_custom_target(
include_directories(
"include"
- ${WAYLAND_SERVER_INCLUDE_DIR}
- ${CAIRO_INCLUDE_DIR}
- ${WESTON_INCLUDE_DIR}
- ${PIXMAN_INCLUDE_DIR}
+ ${WAYLAND_SERVER_INCLUDE_DIRS}
+ ${CAIRO_INCLUDE_DIRS}
+ ${WESTON_INCLUDE_DIRS}
+ ${PIXMAN_INCLUDE_DIRS}
)