summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorLaurent Bigonville <bigon@bigon.be>2018-10-15 11:10:46 +0200
committerLaurent Bigonville <bigon@bigon.be>2018-10-15 13:06:34 +0200
commitdc46a4d942dc1d4d56b752b5b5291ca4aa944d41 (patch)
tree9a7dd600396a5376cb61932865f1b340fea96514 /meson.build
parent91118d84995c9b13f1a30b63ed3ece017dd8b04a (diff)
downloadgeoclue-dc46a4d942dc1d4d56b752b5b5291ca4aa944d41.tar.gz
build: Use join_paths instead of concatenating the paths manually
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index ea08d04..9e86192 100644
--- a/meson.build
+++ b/meson.build
@@ -19,7 +19,7 @@ conf.set_quoted('PACKAGE_STRING', 'geoclue ' + gclue_version)
conf.set_quoted('PACKAGE_URL', 'http://www.freedesktop.org/wiki/Software/GeoClue')
conf.set_quoted('PACKAGE_BUGREPORT', 'http://bugs.freedesktop.org/enter_bug.cgi?product=GeoClue')
conf.set_quoted('TEST_SRCDIR', meson.source_root() + '/data/')
-datadir = get_option('prefix') + '/' + get_option('datadir')
+datadir = join_paths(get_option('prefix'), get_option('datadir'))
conf.set_quoted('LOCALEDIR', datadir + '/locale')
conf.set_quoted('SYSCONFDIR', get_option('sysconfdir'))