summaryrefslogtreecommitdiff
path: root/src/meson.build
diff options
context:
space:
mode:
authorMaciej S. Szmigiero <maciej.szmigiero@oracle.com>2023-01-05 20:47:24 +0100
committerMaciej S. Szmigiero <maciej.szmigiero@oracle.com>2023-01-15 13:50:23 +0100
commitcb66669cff959046c8ef02abe13fc4f1a68660c5 (patch)
treed969ebeecb694d25b007068242916f435d77c7f0 /src/meson.build
parent0cc334a44ed0384785379996e7f20e85f26e624f (diff)
downloadgeoclue-cb66669cff959046c8ef02abe13fc4f1a68660c5.tar.gz
Add static location source
There were many requests to provide a static location source for systems which don't normally move but where the existing location sources provide poor location estimate. An example of such system would be a desktop PC without WiFi or 3G modem. So let's add a source that reads location from "geolocation" file in @sysconfdir@ (normally /etc) to cover this use case. This file is constantly monitored for changes during Geoclue operation and the reported static location is updated accordingly. The geoclue(5) man page should be consulted for the format description of this file.
Diffstat (limited to 'src/meson.build')
-rw-r--r--src/meson.build1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/meson.build b/src/meson.build
index ca6c91f..7a6d020 100644
--- a/src/meson.build
+++ b/src/meson.build
@@ -24,6 +24,7 @@ sources += [ 'gclue-main.c',
'gclue-service-manager.h', 'gclue-service-manager.c',
'gclue-service-client.h', 'gclue-service-client.c',
'gclue-service-location.h', 'gclue-service-location.c',
+ 'gclue-static-source.c', 'gclue-static-source.h',
'gclue-web-source.c', 'gclue-web-source.h',
'gclue-wifi.h', 'gclue-wifi.c',
'gclue-mozilla.h', 'gclue-mozilla.c',