summaryrefslogtreecommitdiff
path: root/docs/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'docs/Makefile.am')
-rw-r--r--docs/Makefile.am70
1 files changed, 70 insertions, 0 deletions
diff --git a/docs/Makefile.am b/docs/Makefile.am
new file mode 100644
index 0000000..f1c666c
--- /dev/null
+++ b/docs/Makefile.am
@@ -0,0 +1,70 @@
+NULL =
+
+AUTOMAKE_OPTIONS = 1.7
+
+# The name of the module.
+DOC_MODULE=geoclue
+
+# The top-level SGML file.
+DOC_MAIN_SGML_FILE=geoclue-docs.xml
+
+# Extra options to supply to gtkdoc-scan
+SCAN_OPTIONS=--ignore-headers=config.h
+
+# The directory containing the source code. Relative to $(srcdir)
+#DOC_SOURCE_DIR=../src
+
+# Used for dependencies
+HFILE_GLOB=
+#$(top_srcdir)/policy/*.h
+CFILE_GLOB=
+#$(top_srcdir)/policy/*.c
+
+# Headers to ignore
+IGNORE_HFILES= \
+ $(NULL)
+
+# Extra options to supply to gtkdoc-mkdb
+MKDB_OPTIONS=--sgml-mode --output-format=xml
+
+# Extra options to supply to gtkdoc-mktmpl
+MKTMPL_OPTIONS=
+
+docs-org.freedesktop.GeoClue2.Manager.xml:
+ cp $(top_srcdir)/src/docs-org.freedesktop.GeoClue2.Manager.xml .
+docs-org.freedesktop.GeoClue2.Client.xml:
+ cp $(top_srcdir)/src/docs-org.freedesktop.GeoClue2.Client.xml .
+docs-org.freedesktop.GeoClue2.Location.xml:
+ cp $(top_srcdir)/src/docs-org.freedesktop.GeoClue2.Location.xml .
+
+# Non-autogenerated SGML files to be included in $(DOC_MAIN_SGML_FILE)
+content_files = \
+ version.xml \
+ docs-org.freedesktop.GeoClue2.Manager.xml \
+ docs-org.freedesktop.GeoClue2.Client.xml \
+ docs-org.freedesktop.GeoClue2.Location.xml \
+ $(NULL)
+
+MAINTAINERCLEANFILES = \
+ *~ \
+ Makefile.in \
+ geoclue.types \
+ geoclue-*.txt \
+ $(NULL)
+
+if ENABLE_GTK_DOC
+include $(top_srcdir)/gtk-doc.make
+else
+CLEANFILES = $(NULL)
+EXTRA_DIST = geoclue-docs.xml
+endif
+
+CLEANFILES += \
+ docs-org.freedesktop.GeoClue2.Manager.xml \
+ docs-org.freedesktop.GeoClue2.Client.xml \
+ docs-org.freedesktop.GeoClue2.Location.xml \
+ $(NULL)
+
+# Version information for marking the documentation
+EXTRA_DIST += version.xml.in
+