summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorLorry Tar Creator <lorry-tar-importer@lorry>2015-12-28 00:06:36 +0000
committerLorry Tar Creator <lorry-tar-importer@lorry>2015-12-28 00:06:36 +0000
commit6eb5949dd99d174393465069c2fd0bab32deddcc (patch)
treed104f72ac2dcb0f592b1c8e06a5af6790bd4080c /Makefile.am
parent482840e61f86ca321838a91e902c41d40c098bbb (diff)
downloadgettext-tarball-6eb5949dd99d174393465069c2fd0bab32deddcc.tar.gz
gettext-0.19.7gettext-0.19.7
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am58
1 files changed, 55 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index b9bd2ba..d95383b 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,5 +1,5 @@
## Makefile for the toplevel directory of GNU gettext
-## Copyright (C) 1995-1999, 2000-2012 Free Software Foundation, Inc.
+## Copyright (C) 1995-2015 Free Software Foundation, Inc.
##
## This program is free software: you can redistribute it and/or modify
## it under the terms of the GNU General Public License as published by
@@ -21,8 +21,37 @@ ACLOCAL_AMFLAGS = -I m4
SUBDIRS = gnulib-local gettext-runtime gettext-tools
+changelog_etc = \
+ gettext-runtime/ChangeLog.0 \
+ gettext-runtime/doc/ChangeLog.0 \
+ gettext-runtime/intl-csharp/ChangeLog.0 \
+ gettext-runtime/intl-java/ChangeLog.0 \
+ gettext-runtime/libasprintf/ChangeLog.0 \
+ gettext-runtime/m4/ChangeLog.0 \
+ gettext-runtime/man/ChangeLog.0 \
+ gettext-runtime/src/ChangeLog.0 \
+ gettext-runtime/tests/ChangeLog.0 \
+ gettext-tools/ChangeLog.0 \
+ gettext-tools/doc/ChangeLog.0 \
+ gettext-tools/doc/ChangeLog.1 \
+ gettext-tools/examples/ChangeLog.0 \
+ gettext-tools/gnulib-tests/ChangeLog.0 \
+ gettext-tools/libgettextpo/ChangeLog.0 \
+ gettext-tools/libgrep/ChangeLog.0 \
+ gettext-tools/m4/ChangeLog.0 \
+ gettext-tools/man/ChangeLog.0 \
+ gettext-tools/man/ChangeLog.1 \
+ gettext-tools/misc/ChangeLog.0 \
+ gettext-tools/projects/ChangeLog.0 \
+ gettext-tools/src/ChangeLog.0 \
+ gettext-tools/src/ChangeLog.1 \
+ gettext-tools/styles/ChangeLog.0 \
+ gettext-tools/tests/ChangeLog.0 \
+ gettext-tools/tests/ChangeLog.1 \
+ gnulib-local/ChangeLog.0
+
EXTRA_DIST = \
- DEPENDENCIES PACKAGING HACKING ChangeLog.0 autogen.sh \
+ $(changelog_etc) DEPENDENCIES PACKAGING HACKING ChangeLog.0 autogen.sh \
build-aux/ac-help.sed build-aux/moopp build-aux/git-version-gen \
m4/fixautomake.m4 m4/woe32-dll.m4 \
m4/libtool.m4
@@ -125,9 +154,32 @@ EXTRA_DIST += $(top_srcdir)/.version
BUILT_SOURCES = $(top_srcdir)/.version
$(top_srcdir)/.version:
echo $(VERSION) > $@-t && mv $@-t $@
-dist-hook:
+dist-hook: gen-ChangeLogs
echo $(VERSION) > $(distdir)/.tarball-version
+# Generate ChangeLog.
+
+gen_start_date = 2015-10-13
+.PHONY: gen-ChangeLogs
+gen-ChangeLogs:
+ $(AM_V_GEN)if test -d .git; then \
+ log_fix="$(srcdir)/build-aux/git-log-fix"; \
+ test -e "$$log_fix" \
+ && amend_git_log="--amend=$$log_fix" \
+ || amend_git_log=; \
+ for d in . gettext-runtime/intl gettext-runtime/po \
+ gettext-tools/po; do \
+ test "$$d" = "." \
+ && cldir="$(distdir)" \
+ || cldir="$(distdir)/$$d"; \
+ $(top_srcdir)/build-aux/gitlog-to-changelog \
+ $$amend_git_log --since=$(gen_start_date) -- "$$d" \
+ > "$$cldir/cl-t" && \
+ { rm -f "$$cldir/ChangeLog" && \
+ mv "$$cldir/cl-t" "$$cldir/ChangeLog"; }; \
+ done; \
+ fi
+
# PO files update.
maintainer-update-po-local: $(top_builddir)/config.status