summaryrefslogtreecommitdiff
path: root/gettext-runtime/Makefile.am
diff options
context:
space:
mode:
authorLorry Tar Creator <lorry-tar-importer@baserock.org>2014-12-24 07:38:37 +0000
committer <>2015-02-02 12:02:29 +0000
commit482840e61f86ca321838a91e902c41d40c098bbb (patch)
tree01ea2e242fd2792d19fe192476601587901db794 /gettext-runtime/Makefile.am
downloadgettext-tarball-482840e61f86ca321838a91e902c41d40c098bbb.tar.gz
Imported from /home/lorry/working-area/delta_gettext-tarball/gettext-0.19.4.tar.xz.gettext-0.19.4
Diffstat (limited to 'gettext-runtime/Makefile.am')
-rw-r--r--gettext-runtime/Makefile.am61
1 files changed, 61 insertions, 0 deletions
diff --git a/gettext-runtime/Makefile.am b/gettext-runtime/Makefile.am
new file mode 100644
index 0000000..823c4f1
--- /dev/null
+++ b/gettext-runtime/Makefile.am
@@ -0,0 +1,61 @@
+## Makefile for the gettext-runtime directory of GNU gettext
+## Copyright (C) 1995-1999, 2000-2006, 2010, 2012 Free Software Foundation, Inc.
+##
+## This program is free software: you can redistribute it and/or modify
+## it under the terms of the GNU General Public License as published by
+## the Free Software Foundation; either version 3 of the License, or
+## (at your option) any later version.
+##
+## This program is distributed in the hope that it will be useful,
+## but WITHOUT ANY WARRANTY; without even the implied warranty of
+## MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+## GNU General Public License for more details.
+##
+## You should have received a copy of the GNU General Public License
+## along with this program. If not, see <http://www.gnu.org/licenses/>.
+
+## Process this file with automake to produce Makefile.in.
+
+AUTOMAKE_OPTIONS = 1.5 gnu no-dependencies
+ACLOCAL_AMFLAGS = -I m4 -I ../m4 -I gnulib-m4
+
+MAKEINFO = env LANG= LC_MESSAGES= LC_ALL= LANGUAGE= @MAKEINFO@
+
+# The list of subdirectories depends on whether --disable-libasprintf was
+# specified.
+if ENABLE_LIBASPRINTF
+SUBDIR_libasprintf = libasprintf
+else
+SUBDIR_libasprintf =
+endif
+SUBDIRS = doc intl intl-java intl-csharp gnulib-lib $(SUBDIR_libasprintf) src po man m4 tests
+
+EXTRA_DIST = BUGS
+
+
+# Files installed for the user and for use by gettextize.
+
+gettextsrcdir = $(datadir)/gettext
+gettextsrc_DATA = ABOUT-NLS
+
+
+all-local: ABOUT-NLS
+
+ABOUT-NLS: $(srcdir)/doc/nls.texi $(srcdir)/doc/matrix.texi
+ rm -f $(srcdir)/ABOUT-NLS \
+ && $(MAKEINFO) --plaintext --no-validate -I $(srcdir)/doc nls.texi \
+ | sed -e "s/\`\([^']*\)'/‘\1’/g" > $(srcdir)/ABOUT-NLS
+
+
+# Allow users to use "gnulib-tool --update".
+EXTRA_DIST += gnulib-m4/gnulib-cache.m4
+
+
+# Woe32 support.
+
+EXTRA_DIST += README.woe32
+
+maintainer-update-po: $(top_builddir)/config.status
+ $(SHELL) ./config.status --recheck
+ $(SHELL) ./config.status po/Makefile.in po-directories
+ cd po && $(MAKE) update-po