summaryrefslogtreecommitdiff
path: root/gettext-tools/Makefile.am
diff options
context:
space:
mode:
authorLorry Tar Creator <lorry-tar-importer@baserock.org>2014-12-24 07:38:37 +0000
committer <>2015-02-02 12:02:29 +0000
commit482840e61f86ca321838a91e902c41d40c098bbb (patch)
tree01ea2e242fd2792d19fe192476601587901db794 /gettext-tools/Makefile.am
downloadgettext-tarball-482840e61f86ca321838a91e902c41d40c098bbb.tar.gz
Imported from /home/lorry/working-area/delta_gettext-tarball/gettext-0.19.4.tar.xz.gettext-0.19.4
Diffstat (limited to 'gettext-tools/Makefile.am')
-rw-r--r--gettext-tools/Makefile.am66
1 files changed, 66 insertions, 0 deletions
diff --git a/gettext-tools/Makefile.am b/gettext-tools/Makefile.am
new file mode 100644
index 0000000..3eb3238
--- /dev/null
+++ b/gettext-tools/Makefile.am
@@ -0,0 +1,66 @@
+## Makefile for the gettext-tools directory of GNU gettext
+## Copyright (C) 1995-1999, 2000-2007, 2010 Free Software Foundation, Inc.
+##
+## This program is free software: you can redistribute it and/or modify
+## it under the terms of the GNU General Public License as published by
+## the Free Software Foundation; either version 3 of the License, or
+## (at your option) any later version.
+##
+## This program is distributed in the hope that it will be useful,
+## but WITHOUT ANY WARRANTY; without even the implied warranty of
+## MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+## GNU General Public License for more details.
+##
+## You should have received a copy of the GNU General Public License
+## along with this program. If not, see <http://www.gnu.org/licenses/>.
+
+## Process this file with automake to produce Makefile.in.
+
+AUTOMAKE_OPTIONS = 1.5 gnu no-dependencies
+ACLOCAL_AMFLAGS = -I m4 -I ../gettext-runtime/m4 -I ../m4 -I gnulib-m4 -I libgrep/gnulib-m4 -I libgettextpo/gnulib-m4
+
+SUBDIRS = doc intl gnulib-lib libgrep src libgettextpo po projects styles misc man m4 tests gnulib-tests examples
+
+EXTRA_DIST = misc/DISCLAIM
+MOSTLYCLEANFILES = core *.stackdump
+
+
+# Files installed for use by gettextize.
+
+gettextsrcdir = $(datadir)/gettext
+gettextsrc_SCRIPTS = ../build-aux/config.rpath
+
+
+# Files installed for the examples.
+
+examplesbuildauxdir = $(docdir)/examples/build-aux
+examplesbuildaux_DATA = \
+ ../build-aux/javacomp.sh.in ../build-aux/javaexec.sh.in \
+ ../build-aux/csharpcomp.sh.in ../build-aux/csharpexec.sh.in
+
+
+# Files copied from other directories.
+
+all-local: $(srcdir)/ABOUT-NLS
+$(srcdir)/ABOUT-NLS: $(srcdir)/../gettext-runtime/ABOUT-NLS
+ cp $(srcdir)/../gettext-runtime/ABOUT-NLS $(srcdir)/ABOUT-NLS
+
+
+# Allow users to use "gnulib-tool --update".
+EXTRA_DIST += gnulib-m4/gnulib-cache.m4
+
+
+# Woe32 support.
+
+EXTRA_DIST += README.woe32
+
+
+# Cygwin support.
+
+EXTRA_DIST += woe32dll/export.h
+
+maintainer-update-po: $(top_builddir)/config.status
+ $(SHELL) ./config.status --recheck
+ $(SHELL) ./config.status po/Makefile.in po-directories
+ cd po && $(MAKE) update-po
+ cd examples && $(MAKE) maintainer-update-po