summaryrefslogtreecommitdiff
path: root/gettext-tools/examples/hello-librep/Makefile.am
diff options
context:
space:
mode:
authorLorry Tar Creator <lorry-tar-importer@baserock.org>2014-12-24 07:38:37 +0000
committer <>2015-02-02 12:02:29 +0000
commit482840e61f86ca321838a91e902c41d40c098bbb (patch)
tree01ea2e242fd2792d19fe192476601587901db794 /gettext-tools/examples/hello-librep/Makefile.am
downloadgettext-tarball-482840e61f86ca321838a91e902c41d40c098bbb.tar.gz
Imported from /home/lorry/working-area/delta_gettext-tarball/gettext-0.19.4.tar.xz.gettext-0.19.4
Diffstat (limited to 'gettext-tools/examples/hello-librep/Makefile.am')
-rw-r--r--gettext-tools/examples/hello-librep/Makefile.am29
1 files changed, 29 insertions, 0 deletions
diff --git a/gettext-tools/examples/hello-librep/Makefile.am b/gettext-tools/examples/hello-librep/Makefile.am
new file mode 100644
index 0000000..86f0708
--- /dev/null
+++ b/gettext-tools/examples/hello-librep/Makefile.am
@@ -0,0 +1,29 @@
+# Example for use of GNU gettext.
+# This file is in the public domain.
+#
+# Makefile configuration - processed by automake.
+
+# General automake options.
+AUTOMAKE_OPTIONS = foreign
+ACLOCAL_AMFLAGS = -I m4
+
+# The list of subdirectories containing Makefiles.
+SUBDIRS = m4 po
+
+# The list of programs that are built.
+bin_SCRIPTS = hello
+
+# Compilation of librep programs.
+SUFFIXES = .jl .jlc
+.jl.jlc:
+ rep --batch --no-rc -l compiler -f compile-batch $<
+CLEANFILES = *.jlc
+
+# Making a librep program executable.
+hello: hello.jlc
+ (echo '#!@REP@'; echo '!#'; cat $<) > $@
+ chmod a+x $@
+CLEANFILES += hello
+
+# Additional files to be distributed.
+EXTRA_DIST = autogen.sh autoclean.sh