summaryrefslogtreecommitdiff
path: root/gettext-tools/examples/hello-c++-qt/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'gettext-tools/examples/hello-c++-qt/configure.ac')
-rw-r--r--gettext-tools/examples/hello-c++-qt/configure.ac23
1 files changed, 23 insertions, 0 deletions
diff --git a/gettext-tools/examples/hello-c++-qt/configure.ac b/gettext-tools/examples/hello-c++-qt/configure.ac
new file mode 100644
index 0000000..9858a52
--- /dev/null
+++ b/gettext-tools/examples/hello-c++-qt/configure.ac
@@ -0,0 +1,23 @@
+dnl Example for use of GNU gettext.
+dnl This file is in the public domain.
+dnl
+dnl Configuration file - processed by autoconf.
+
+AC_INIT
+AC_CONFIG_SRCDIR(hello.cc)
+AM_INIT_AUTOMAKE(hello-c++-qt, 0)
+
+AC_PROG_CXX
+FUN_TYPE_BOOL
+AC_CHECK_HEADERS([unistd.h])
+FUN_HEADER_STDCXX
+FUN_CHECK_PTHREAD
+FUN_CHECK_QT(220)
+
+dnl Support for the po directory.
+AM_PO_SUBDIRS
+
+AC_CONFIG_FILES([Makefile])
+AC_CONFIG_FILES([m4/Makefile])
+AC_CONFIG_FILES([po/Makefile], [AM_POSTPROCESS_PO_MAKEFILE])
+AC_OUTPUT