summaryrefslogtreecommitdiff
path: root/gettext-tools/examples/hello-c++-wxwidgets/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'gettext-tools/examples/hello-c++-wxwidgets/configure.ac')
-rw-r--r--gettext-tools/examples/hello-c++-wxwidgets/configure.ac23
1 files changed, 23 insertions, 0 deletions
diff --git a/gettext-tools/examples/hello-c++-wxwidgets/configure.ac b/gettext-tools/examples/hello-c++-wxwidgets/configure.ac
new file mode 100644
index 0000000..a25a6b9
--- /dev/null
+++ b/gettext-tools/examples/hello-c++-wxwidgets/configure.ac
@@ -0,0 +1,23 @@
+dnl Example for use of GNU gettext.
+dnl This file is in the public domain.
+dnl
+dnl Configuration file - processed by autoconf.
+
+AC_INIT
+AC_CONFIG_SRCDIR(hello.cc)
+AM_INIT_AUTOMAKE(hello-c++-wxwidgets, 0)
+
+AC_PROG_CXX
+AC_CHECK_HEADERS([unistd.h])
+
+AM_OPTIONS_WXCONFIG
+AM_PATH_WXCONFIG([2.6.0], [], [AC_MSG_ERROR([wxWidgets not found])])
+AC_LIB_LINKFLAGS_FROM_LIBS([WX_LDADD], [$WX_LIBS])
+
+dnl Support for the po directory.
+AM_PO_SUBDIRS
+
+AC_CONFIG_FILES([Makefile])
+AC_CONFIG_FILES([m4/Makefile])
+AC_CONFIG_FILES([po/Makefile], [AM_POSTPROCESS_PO_MAKEFILE])
+AC_OUTPUT