summaryrefslogtreecommitdiff
path: root/gettext-tools/examples/hello-pascal/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'gettext-tools/examples/hello-pascal/configure.ac')
-rw-r--r--gettext-tools/examples/hello-pascal/configure.ac38
1 files changed, 38 insertions, 0 deletions
diff --git a/gettext-tools/examples/hello-pascal/configure.ac b/gettext-tools/examples/hello-pascal/configure.ac
new file mode 100644
index 0000000..76920b8
--- /dev/null
+++ b/gettext-tools/examples/hello-pascal/configure.ac
@@ -0,0 +1,38 @@
+dnl Example for use of GNU gettext.
+dnl This file is in the public domain.
+dnl
+dnl Configuration file - processed by autoconf.
+
+AC_INIT
+AC_CONFIG_SRCDIR(hello.pas)
+AM_INIT_AUTOMAKE(hello-pascal, 0)
+
+dnl Check for availability of the Free Pascal Compiler.
+AC_PATH_PROG(PPC, ppc386)
+if test -z "$PPC"; then
+ echo "*** Essential program ppc386 not found" 1>&2
+ exit 1
+fi
+AC_SUBST(PPC)
+
+dnl The installed program must know where to find its message catalogs.
+dnl Unfortunately, prefix gets only finally determined at the end of configure.
+if test "X$prefix" = "XNONE"; then
+ final_prefix="$ac_default_prefix"
+else
+ final_prefix="$prefix"
+fi
+save_prefix="$prefix"
+prefix="$final_prefix"
+eval "datarootdir=\"${datarootdir}\""
+eval "localedir=\"${datadir}/locale\""
+prefix="$save_prefix"
+AC_SUBST(localedir)
+
+dnl Support for the po directory.
+AM_PO_SUBDIRS
+
+AC_CONFIG_FILES([Makefile])
+AC_CONFIG_FILES([m4/Makefile])
+AC_CONFIG_FILES([po/Makefile], [AM_POSTPROCESS_PO_MAKEFILE])
+AC_OUTPUT