summaryrefslogtreecommitdiff
path: root/gettext-tools/examples/hello-python/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'gettext-tools/examples/hello-python/Makefile.am')
-rw-r--r--gettext-tools/examples/hello-python/Makefile.am26
1 files changed, 26 insertions, 0 deletions
diff --git a/gettext-tools/examples/hello-python/Makefile.am b/gettext-tools/examples/hello-python/Makefile.am
new file mode 100644
index 0000000..009e9f3
--- /dev/null
+++ b/gettext-tools/examples/hello-python/Makefile.am
@@ -0,0 +1,26 @@
+# Example for use of GNU gettext.
+# This file is in the public domain.
+#
+# Makefile configuration - processed by automake.
+
+# General automake options.
+AUTOMAKE_OPTIONS = foreign
+ACLOCAL_AMFLAGS = -I m4
+
+# The list of subdirectories containing Makefiles.
+SUBDIRS = m4 po
+
+# The list of programs that are built.
+bin_SCRIPTS = hello
+
+# Making a Python program executable.
+# FIXME: How to make a compiled python program (output of automake's
+# py-compile command) executable?
+hello: hello.py
+ (echo '#!@PYTHON@'; cat $<) > $@
+ chmod a+x $@
+CLEANFILES = hello
+#CLEANFILES += *.pyc *.pyo
+
+# Additional files to be distributed.
+EXTRA_DIST = autogen.sh autoclean.sh