summaryrefslogtreecommitdiff
path: root/gettext-tools/gnulib-lib/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'gettext-tools/gnulib-lib/Makefile.am')
-rw-r--r--gettext-tools/gnulib-lib/Makefile.am7
1 files changed, 6 insertions, 1 deletions
diff --git a/gettext-tools/gnulib-lib/Makefile.am b/gettext-tools/gnulib-lib/Makefile.am
index 9e43721..25c9cc1 100644
--- a/gettext-tools/gnulib-lib/Makefile.am
+++ b/gettext-tools/gnulib-lib/Makefile.am
@@ -1,5 +1,5 @@
## Makefile for the gettext-tools/gnulib-lib subdirectory of GNU gettext
-## Copyright (C) 1995-1998, 2000-2006, 2009, 2015 Free Software
+## Copyright (C) 1995-1998, 2000-2006, 2009, 2015-2016 Free Software
## Foundation, Inc.
##
## This program is free software: you can redistribute it and/or modify
@@ -61,6 +61,11 @@ include Makefile.gnulib
# Which classes to export from the shared library.
MOOPPFLAGS += --dllexport=styled_ostream
+# OS/2 does not support a DLL name longer than 8 characters.
+if OS2
+libgettextlib_la_LDFLAGS += -os2dllname gtlib
+endif
+
# Linking with C++ libraries is needed _only_ on mingw and Cygwin.
if !WOE32DLL
libgettextlib_la_LINK = $(LIBTOOL) $(AM_V_lt) --tag=CC \