summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorChris Liddell <chris.liddell@artifex.com>2019-09-19 11:02:48 +0100
committerChris Liddell <chris.liddell@artifex.com>2019-09-19 15:57:40 +0100
commit071b96290c5e524291bb33b132e2cea3efd5f98e (patch)
tree4f80c672db53a615b420605890beceba07ecb508 /configure.ac
parentd9889892feaac3ca09f85d9bbdc001b1aec50cc3 (diff)
downloadghostpdl-071b96290c5e524291bb33b132e2cea3efd5f98e.tar.gz
Make missing jbig2 decoder fatal error.
If we have neither Luratech nor jbig2dec, have configure fail, unless explicitly run with --without-jbig2dec
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 3 insertions, 6 deletions
diff --git a/configure.ac b/configure.ac
index c5ddefe7d..3b72367dc 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1621,6 +1621,7 @@ if test x$with_luratech != xno; then
fi
JB2_STDINT_TYPES_IN=
+JBIG2DEC_REQ=0.16
if test "x$JBIG2_DECODER" = x; then
dnl look for jbig2dec
@@ -1680,7 +1681,6 @@ if test "x$JBIG2_DECODER" = x; then
# autoconf macro and b) requires pkg-config on the system, which is
# NOT standard on ANY OS, including Linux!
if test "x$PKGCONFIG" != x; then
- JBIG2DEC_REQ=0.16
AC_MSG_CHECKING(for jbig2dec $JBIG2DEC_REQ with pkg-config)
if $PKGCONFIG --atleast-version=$JBIG2DEC_REQ jbig2dec; then
AC_MSG_RESULT(yes)
@@ -1688,17 +1688,14 @@ if test "x$JBIG2_DECODER" = x; then
JBIG2DEC_LIBS="`$PKGCONFIG --libs jbig2dec`"
SHARE_JBIG2=1
else
- AC_MSG_RESULT(no)
- AC_MSG_WARN([disabling support for JBIG2 files])
- with_jbig2dec=no
+ AC_MSG_ERROR([jbig2 decoder not found, or too old])
fi
else
AC_MSG_CHECKING(for jbig2dec library)
AC_CHECK_LIB([jbig2dec], [jbig2_page_out], [
SHARE_JBIG2=1
], [
- AC_MSG_WARN([disabling support for JBIG2 files])
- with_jbig2dec=no
+ AC_MSG_ERROR([jbig2 decoder not found, or too old])
])
fi
if test x$with_jbig2dec != xno; then