summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorChris Liddell <chris.liddell@artifex.com>2021-05-07 14:48:32 +0100
committerChris Liddell <chris.liddell@artifex.com>2021-05-07 14:48:32 +0100
commit15f9f3fb2eff2fe5896d32b29672ab3b080aca9c (patch)
treee774de9471c180420d909480eb86be6c7779d503 /configure.ac
parent4874418fd031617212336b8b55f8fcba3b9cfb68 (diff)
downloadghostpdl-15f9f3fb2eff2fe5896d32b29672ab3b080aca9c.tar.gz
Add some relevant flags to the cups compilation
Specifically: HAVE_STRLCAT, HAVE_STRLCPY, HAVE_SNPRINTF, HAVE_VSNPRINTF In the hope it might resolve the strange and unpredictable compilation failures on the 32 bit cluster auto tests.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index d938d2dce..9bcfb9d91 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1882,6 +1882,10 @@ if ( test -f $srcdir/cups/gdevcups.c ); then
AC_MSG_WARN([USING LOCAL CUPS SOURCE])
SHARELCUPS=0
SHARELCUPSI=0
+ AC_CHECK_FUNCS([strlcat], [CUPSCFLAGS="$CUPSCFLAGS -DHAVE_STRLCAT=1"], [])
+ AC_CHECK_FUNCS([strlcpy], [CUPSCFLAGS="$CUPSCFLAGS -DHAVE_STRLCPY=1"], [])
+ AC_CHECK_FUNCS([snprintf], [CUPSCFLAGS="$CUPSCFLAGS -DHAVE_SNPRINTF=1"], [])
+ AC_CHECK_FUNCS([vsnprintf], [CUPSCFLAGS="$CUPSCFLAGS -DHAVE_VSNPRINTF=1"], [])
LCUPSBUILDTYPE=linux
LCUPSINCLUDE="include \$(GLSRCDIR)/lcups.mak"
LCUPSIINCLUDE="include \$(GLSRCDIR)/lcupsi.mak"