summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAlex Cherepanov <alex@coscript.biz>2021-08-11 09:15:18 +0100
committerChris Liddell <chris.liddell@artifex.com>2021-08-13 14:53:25 +0100
commit21d5eca51fffa804883cb54b496a0ea065e8dbde (patch)
tree82727a279df26352c2174100b8087a8125c4ea11 /configure.ac
parent6ff7c91d945c79af72a09165b43f68192210c16f (diff)
downloadghostpdl-21d5eca51fffa804883cb54b496a0ea065e8dbde.tar.gz
Update configure.ac for newer autoconf versions
Also tweak order of operations in autogen.sh so config.guess and install-sh are in place before we call autoreconf
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac175
1 files changed, 82 insertions, 93 deletions
diff --git a/configure.ac b/configure.ac
index 8b62e2fe9..eddc08e6d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -20,7 +20,7 @@ dnl Initialization and Versioning
dnl ------------------------------------------------
AC_INIT
-AC_PREREQ(2.63)
+AC_PREREQ([2.63])
AC_LANG(C)
AC_CONFIG_SRCDIR(psi/gs.c)
@@ -241,7 +241,7 @@ dnl --------------------------------------------------
dnl Allow excluding the contributed drivers
dnl --------------------------------------------------
-AC_ARG_ENABLE([contrib], AC_HELP_STRING([--disable-contrib], [Do not include contributed drivers]))
+AC_ARG_ENABLE([contrib], AS_HELP_STRING([--disable-contrib], [Do not include contributed drivers]))
CONTRIBINCLUDE="include $srcdir/contrib/contrib.mak"
INSTALL_CONTRIB="install-contrib-extras"
@@ -356,13 +356,13 @@ else
fi
AC_MSG_CHECKING([if compiler supports restrict])
-AC_TRY_COMPILE([
+AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[
#if defined(__STDC_VERSION__) && __STDC_VERSION__ == 199901L
void test (char * restrict p){}
#else
void test (char * __restrict p){}
#endif
-],[
+]], [[
#if defined(__STDC_VERSION__) && __STDC_VERSION__ == 199901L
char *restrict t;
#else
@@ -370,7 +370,7 @@ void test (char * __restrict p){}
#endif
test(t);
return 1;
- ],[
+ ]])],[
CFLAGS="$CFLAGS -DHAVE_RESTRICT=1"
if test x"$host" = x"$build" ; then
CFLAGSAUX="$CFLAGSAUX -DHAVE_RESTRICT=1"
@@ -384,7 +384,7 @@ void test (char * __restrict p){}
-AC_ARG_WITH([arch_h], AC_HELP_STRING([--with-arch_h=<arch.h to use>],
+AC_ARG_WITH([arch_h], AS_HELP_STRING([--with-arch_h=<arch.h to use>],
[Use a custom arch.h (must be an absolute path)]),[], [with_arch_h=])
ARCH_CONF_HEADER=
@@ -416,7 +416,7 @@ fi
AC_SUBST(ARCH_CONF_HEADER)
# debug configurarion is available by default with "make debug"
-#AC_ARG_ENABLE([debug], AC_HELP_STRING([--enable-debug],
+#AC_ARG_ENABLE([debug], AS_HELP_STRING([--enable-debug],
# [turn on debugging]))
#if test x$enable_debug = xyes; then
# optflags_to_try="-g"
@@ -430,28 +430,28 @@ old_cflags=$CFLAGS
for flag in $optflags_to_try; do
CFLAGS="$CFLAGS $flag"
- AC_TRY_COMPILE(, [return 0;], [
+ AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[]], [[return 0;]])],[
echo " $flag"
OPT_CFLAGS="$OPT_CFLAGS $flag"
- ])
+ ],[])
CFLAGS=$old_cflags
done
for flag in $cflags_to_try; do
CFLAGS="$CFLAGS $flag"
- AC_TRY_COMPILE(, [return 0;], [
+ AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[]], [[return 0;]])],[
echo " $flag"
GCFLAGS="$GCFLAGS $flag"
- ])
+ ],[])
CFLAGS=$old_cflags
done
old_cflags=$CFLAGS
for flag in $dbgflags_to_try; do
CFLAGS="$CFLAGS $flag"
- AC_TRY_COMPILE(, [return 0;], [
+ AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[]], [[return 0;]])],[
echo " $flag"
DBG_CFLAGS="$DBG_CFLAGS $flag"
- ])
+ ],[])
CFLAGS=$old_cflags
done
@@ -459,10 +459,10 @@ CFLAGS_VISIBILITY=""
for flag in $CC_VISIBILITY_FLAGS_TO_TRY; do
CFLAGS="$CFLAGS $flag"
- AC_TRY_COMPILE(, [return 0;], [
+ AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[]], [[return 0;]])],[
echo " $flag"
CFLAGS_VISIBILITY="$CFLAGS_VISIBILITY $flag"
- ])
+ ],[])
CFLAGS=$old_cflags
done
@@ -473,7 +473,7 @@ dnl check for sanitize support
dnl ----------------------------
AC_MSG_CHECKING([compiler/linker address santizer support])
-AC_ARG_WITH([sanitizer], AC_HELP_STRING([--with-sanitizer=@<:@address/memory@:>@],
+AC_ARG_WITH([sanitizer], AS_HELP_STRING([--with-sanitizer=@<:@address/memory@:>@],
[Sanitizer for 'sanitize' target (defaults to 'address')]),
[SANITIZER=$with_sanitizer], [SANITIZER=address])
@@ -524,7 +524,9 @@ dnl ----------------------------
dnl check for big/little endian
dnl ----------------------------
-AC_C_BIGENDIAN([BIGENDIAN=1], [BIGENDIAN=0])
+AC_C_BIGENDIAN([BIGENDIAN=1], [BIGENDIAN=0],
+ [AC_MSG_ERROR([Endian status cannot be determined])],
+ [AC_MSG_ERROR([Building of universal binaries is not implemented.])])
dnl --------------------------------------------------
dnl check for sse2 intrinsics
@@ -544,7 +546,7 @@ AC_LINK_IFELSE(
])],
[HAVE_SSE2="-DHAVE_SSE2"], [HAVE_SSE2=""])
-AC_ARG_ENABLE([sse2], AC_HELP_STRING([--disable-sse2],
+AC_ARG_ENABLE([sse2], AS_HELP_STRING([--disable-sse2],
[Do not use sse2 instrinsics]), [
if test "x$enable_sse2" = xno; then
HAVE_SSE2=""
@@ -563,7 +565,7 @@ CFLAGS=$save_cflags
dnl --------------------------------------------------
dnl Enable thread safe build
dnl --------------------------------------------------
-AC_ARG_ENABLE([threadsafe], AC_HELP_STRING([--enable-threadsafe],
+AC_ARG_ENABLE([threadsafe], AS_HELP_STRING([--enable-threadsafe],
[enable a thread safe build - NOTE: this will exclude non-threadsafe devices]))
if test x$enable_threadsafe = xyes ; then
CFLAGS="-DGS_THREADSAFE"
@@ -574,7 +576,6 @@ dnl Check for headers
dnl --------------------------------------------------
AC_HEADER_DIRENT
-AC_HEADER_STDC
AC_CHECK_HEADERS([errno.h fcntl.h limits.h malloc.h memory.h stdlib.h string.h strings.h sys/ioctl.h sys/param.h sys/time.h sys/times.h syslog.h unistd.h dirent.h ndir.h sys/dir.h sys/ndir.h inttypes.h])
dnl --------------------------------------------------
@@ -614,7 +615,6 @@ AC_TYPE_MODE_T
AC_TYPE_OFF_T
AC_TYPE_SIZE_T
AC_STRUCT_ST_BLOCKS
-AC_HEADER_TIME
AC_STRUCT_TM
dnl see if we're on a system that puts the *int*_t types
@@ -779,7 +779,7 @@ SYNC="nosync"
PTHREAD_LIBS=""
RECURSIVE_MUTEXATTR=""
-AC_ARG_ENABLE([threading], AC_HELP_STRING([--disable-threading],
+AC_ARG_ENABLE([threading], AS_HELP_STRING([--disable-threading],
[disable support for multithreaded rendering]))
# if you haven't got pread/pwrite, we can't use multithreading
@@ -791,8 +791,7 @@ if test "x$HAVE_PREAD_PWRITE" != "x"; then
PTHREAD_LIBS="-lpthread"
])
AC_MSG_CHECKING([for recursive mutexes])
- AC_TRY_COMPILE([#include <pthread.h>],
- [
+ AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[#include <pthread.h>]], [[
static int k = PTHREAD_MUTEX_RECURSIVE;
#ifndef pthread_mutexattr_settype
#ifdef __cplusplus
@@ -803,11 +802,8 @@ if test "x$HAVE_PREAD_PWRITE" != "x"; then
#endif
;
return 0;
- ],
- [RECURSIVE_MUTEXATTR="-DGS_RECURSIVE_MUTEXATTR=PTHREAD_MUTEX_RECURSIVE"
- mutex_result="PTHREAD_MUTEX_RECURSIVE"],
- [AC_TRY_COMPILE([#include <pthread.h>],
- [
+ ]])],[RECURSIVE_MUTEXATTR="-DGS_RECURSIVE_MUTEXATTR=PTHREAD_MUTEX_RECURSIVE"
+ mutex_result="PTHREAD_MUTEX_RECURSIVE"],[AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[#include <pthread.h>]], [[
static int k = PTHREAD_MUTEX_RECURSIVE_NP;
#ifndef pthread_mutexattr_settype
#ifdef __cplusplus
@@ -818,9 +814,8 @@ if test "x$HAVE_PREAD_PWRITE" != "x"; then
#endif
;
return 0;
- ],
- [RECURSIVE_MUTEXATTR="-DGS_RECURSIVE_MUTEXATTR=PTHREAD_MUTEX_RECURSIVE_NP"
- mutex_result="PTHREAD_MUTEX_RECURSIVE_NP"])])
+ ]])],[RECURSIVE_MUTEXATTR="-DGS_RECURSIVE_MUTEXATTR=PTHREAD_MUTEX_RECURSIVE_NP"
+ mutex_result="PTHREAD_MUTEX_RECURSIVE_NP"],[])])
AC_MSG_RESULT($mutex_result)
fi
fi
@@ -838,7 +833,7 @@ TESSERACTINCLUDE=
TESSERACT_LIBS=
OCR_DEVS=
-AC_ARG_WITH([tesseract], AC_HELP_STRING([--without-tesseract],
+AC_ARG_WITH([tesseract], AS_HELP_STRING([--without-tesseract],
[do not try to use the Tesseract library for OCR]))
if test x$with_tesseract != xno; then
@@ -846,10 +841,7 @@ if test x$with_tesseract != xno; then
if test -d $srcdir/tesseract && test -d $srcdir/leptonica; then
AC_MSG_RESULT([yes])
AC_LANG_PUSH(C++)
- AC_TRY_COMPILE([],
- [return 0;],
- [HAVE_CXX_COMPILER=yes; AC_SUBST(CXX)],
- [HAVE_CXX_COMPILER=no])
+ AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[]], [[return 0;]])],[HAVE_CXX_COMPILER=yes; AC_SUBST(CXX)],[HAVE_CXX_COMPILER=no])
if test x$HAVE_CXX_COMPILER != xyes; then
AC_MSG_WARN([Disabling tesseract as no working C++ compiler])
elif test x$SYNC = xnosync ; then
@@ -864,9 +856,9 @@ if test x$with_tesseract != xno; then
for flag in $cxxflags_to_try ; do
CXXFLAGS="$CXXFLAGS $flag"
- AC_TRY_COMPILE([#include <cstdlib>], [return 0;], [
+ AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[#include <cstdlib>]], [[return 0;]])],[
echo " $flag"; CXXFLAGS_TO_USE="$CXXFLAGS_TO_USE $flag"
- ])
+ ],[])
CXXFLAGS="$old_cflags"
done
@@ -1008,7 +1000,7 @@ AC_SUBST(TESS_CXXFLAGS)
dnl Tests for iconv (Needed for OpenPrinting Vector, "opvp" output device)
AC_ARG_WITH(libiconv,
- [AC_HELP_STRING([--with-libiconv=@<:@no/gnu/native@:>@],
+ [AS_HELP_STRING([--with-libiconv=@<:@no/gnu/native@:>@],
[use the libiconv library])],,
[with_libiconv=maybe])
found_iconv=no
@@ -1051,7 +1043,7 @@ esac
dnl Check for libidn (needed for Unicode password support)
AC_ARG_WITH(libidn,
- [AC_HELP_STRING([--without-libidn],
+ [AS_HELP_STRING([--without-libidn],
[Do not use libidn to support Unicode passwords])],,
[with_libidn=maybe])
@@ -1096,7 +1088,7 @@ AC_SUBST(UTF8DEVS)
dnl Tests for libpaper (to determine system default paper size)
AC_ARG_WITH([libpaper],
- AC_HELP_STRING([--without-libpaper],
+ AS_HELP_STRING([--without-libpaper],
[disable libpaper support]))
if test x$with_libpaper != xno; then
AC_CHECK_LIB(paper, systempapername, [with_libpaper=yes],
@@ -1123,7 +1115,7 @@ dnl Fontconfig support
HAVE_FONTCONFIG=""
FONTCONFIG_CFLAGS=""
FONTCONFIG_LIBS=""
-AC_ARG_ENABLE([fontconfig], AC_HELP_STRING([--disable-fontconfig],
+AC_ARG_ENABLE([fontconfig], AS_HELP_STRING([--disable-fontconfig],
[Do not use fontconfig to list system fonts]))
if test "$enable_fontconfig" != "no"; then
# We MUST NOT use PKG_CHECK_MODULES since it is a) not a standard
@@ -1157,7 +1149,7 @@ dnl DBus support
HAVE_DBUS=""
DBUS_CFLAGS=""
DBUS_LIBS=""
-AC_ARG_ENABLE([dbus], AC_HELP_STRING([--disable-dbus],
+AC_ARG_ENABLE([dbus], AS_HELP_STRING([--disable-dbus],
[Do not use dbus to communicate with external services]))
if test "$enable_dbus" != "no"; then
if test "x$PKGCONFIG" != x; then
@@ -1185,7 +1177,7 @@ AC_SUBST(DBUS_CFLAGS)
AC_SUBST(DBUS_LIBS)
-AC_ARG_ENABLE([freetype], AC_HELP_STRING([--disable-freetype],
+AC_ARG_ENABLE([freetype], AS_HELP_STRING([--disable-freetype],
[Disable freetype for font rasterization]))
FT_BRIDGE=0
@@ -1203,7 +1195,7 @@ FAPIUFST_MAK="\$(GLSRCDIR)\$(D)stub.mak"
if test x"$enable_fapi" != xno; then
dnl UFST detection
- AC_ARG_WITH([ufst], AC_HELP_STRING([--with-ufst=UFST_ROOT_DIR],
+ AC_ARG_WITH([ufst], AS_HELP_STRING([--with-ufst=UFST_ROOT_DIR],
[Use UFST]),
[], [with_ufst=no])
@@ -1396,7 +1388,7 @@ fi
# this option is useful if you're cross-compiling and want to use
# your toolchain's zlib for $host but the local one for $build
-AC_ARG_WITH([local-zlib], AC_HELP_STRING([--without-local-zlib],
+AC_ARG_WITH([local-zlib], AS_HELP_STRING([--without-local-zlib],
[do not check for local zlib sources (has no effect on AUX toolchain when cross-building)]))
AC_MSG_CHECKING([for local zlib source])
@@ -1550,10 +1542,10 @@ AC_SUBST(LCMS2MTDIR)
dnl look for libtiff, it also requires lib
dnl png for the png output device; it also requires zlib
-AC_ARG_WITH([libtiff], AC_HELP_STRING([--without-libtiff],
+AC_ARG_WITH([libtiff], AS_HELP_STRING([--without-libtiff],
[disable use of libtiff]), with_libtiff=no)
-AC_ARG_WITH([system-libtiff], AC_HELP_STRING([--with-system-libtiff],
+AC_ARG_WITH([system-libtiff], AS_HELP_STRING([--with-system-libtiff],
[Force using the systems libtiff]),
[], [with_system_libtiff=check])
@@ -1667,12 +1659,10 @@ fi
CGLAGS_STORE=$CFLAGS
CFLAGS=-Wno-misleading-indentation
-AC_TRY_COMPILE([], [return 0;],
- [CFLAGS_NMI="-Wno-misleading-indentation"],[CFLAGS_NMI=""])
+AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[]], [[return 0;]])],[CFLAGS_NMI="-Wno-misleading-indentation"],[CFLAGS_NMI=""])
CFLAGS=-Wno-undef
-AC_TRY_COMPILE([], [return 0;],
- [CFLAGS_NUD="-Wno-undef"],[CFLAGS_NUD=""])
+AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[]], [[return 0;]])],[CFLAGS_NUD="-Wno-undef"],[CFLAGS_NUD=""])
CFLAGS=$CGLAGS_STORE
@@ -1753,24 +1743,24 @@ AC_SUBST(EXPAT_CFLAGS)
AC_SUBST(EXPAT_LIBS)
dnl look for CUPS...
-AC_ARG_ENABLE([cups], AC_HELP_STRING([--disable-cups],
+AC_ARG_ENABLE([cups], AS_HELP_STRING([--disable-cups],
[Do not include CUPS support]))
-AC_ARG_WITH([pdftoraster], AC_HELP_STRING([--without-pdftoraster],
+AC_ARG_WITH([pdftoraster], AS_HELP_STRING([--without-pdftoraster],
[Do not include CUPS' pdftoraster filter]))
-AC_ARG_WITH([local-cups], AC_HELP_STRING([--with-local-cups],
+AC_ARG_WITH([local-cups], AS_HELP_STRING([--with-local-cups],
[Force using the GS supplied cups code - only useful for debugging]),
[with_local_cups=yes], [with_local_cups=no])
-AC_ARG_WITH([cups-serverbin], AC_HELP_STRING([--with-cups-serverbin],
+AC_ARG_WITH([cups-serverbin], AS_HELP_STRING([--with-cups-serverbin],
[override the "cups-config --serverbin" path]), CUPS_SERVERBIN="$withval", CUPS_SERVERBIN="")
-AC_ARG_WITH([cups-serverroot], AC_HELP_STRING([--with-cups-serverroot],
+AC_ARG_WITH([cups-serverroot], AS_HELP_STRING([--with-cups-serverroot],
[override the "cups-config --serverroot" path]), CUPS_SERVERROOT="$withval", CUPS_SERVERROOT="")
-AC_ARG_WITH([cups-datadir], AC_HELP_STRING([--with-cups-datadir],
+AC_ARG_WITH([cups-datadir], AS_HELP_STRING([--with-cups-datadir],
[override the "cups-config --datadir" path]), CUPS_DATADIR="$withval", CUPS_DATADIR="")
CUPSDEV=""
@@ -1915,7 +1905,7 @@ AC_SUBST(LCUPSIINCLUDE)
AC_SUBST(CUPSPDFTORASTER)
dnl look for IJS implementation
-AC_ARG_WITH([ijs], AC_HELP_STRING([--without-ijs],
+AC_ARG_WITH([ijs], AS_HELP_STRING([--without-ijs],
[disable IJS driver support]))
case $host in
@@ -1967,7 +1957,7 @@ JBIG2DEC_REQ=0.19
if test "x$JBIG2_DECODER" = x; then
dnl look for jbig2dec
- AC_ARG_WITH([jbig2dec], AC_HELP_STRING([--without-jbig2dec],
+ AC_ARG_WITH([jbig2dec], AS_HELP_STRING([--without-jbig2dec],
[disable JBIG2 decode support]))
if test x$with_jbig2dec != xno; then
AC_MSG_CHECKING([for local jbig2dec library source])
@@ -1982,12 +1972,12 @@ if test "x$JBIG2_DECODER" = x; then
for include in sys/types.h inttypes.h sys/inttypes.h sys/int_types.h ; do
AC_MSG_CHECKING([for uint32_t in $include])
- AC_TRY_COMPILE([#include <$include>], [uint32_t canary;], [
+ AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[#include <$include>]], [[uint32_t canary;]])],[
AC_MSG_RESULT([yes])
stdint_types_in="$include"
break;
- ], AC_MSG_RESULT([no])
- )
+ ],[AC_MSG_RESULT(no)
+ ])
done
case "$stdint_types_in" in
@@ -2099,7 +2089,7 @@ fi
AC_CHECK_DECL(lrintf, , [OPJ_LRINTF_SUBST="-D\"lrintf(a)\"=\"((long)(a+0.5))\"]",[[#include <math.h>]])
-AC_ARG_ENABLE([openjpeg], AC_HELP_STRING([--disable-openjpeg],
+AC_ARG_ENABLE([openjpeg], AS_HELP_STRING([--disable-openjpeg],
[Do not use OpenJPEG for JPX decoding]))
OPENJPEGDIR=$srcdir/openjpeg
@@ -2122,7 +2112,7 @@ if test "x$JPX_DECODER" = "x"; then
CFLAGS_old="$CFLAGS"
CFLAGS="-Wno-attributes"
- AC_TRY_COMPILE([], [return 0;], [JPX_AUTOCONF_CFLAGS="$JPX_AUTOCONF_CFLAGS -Wno-attributes"])
+ AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[]], [[return 0;]])],[JPX_AUTOCONF_CFLAGS="$JPX_AUTOCONF_CFLAGS -Wno-attributes"],[])
CFLAGS="$CFLAGS_old"
JPX_AUTOCONF_CFLAGS="$JPX_AUTOCONF_CFLAGS -DOPJ_STATIC -DMUTEX_pthread=0 $OPJ_LRINTF_SUBST -DUSE_JPIP -DUSE_OPENJPEG_JP2 $CFLAGS_OPJ_HAVE_STDINT_H $CFLAGS_OPJ_HAVE_INTTYPES_H $CFLAGS_OPJ_BIGENDIAN $CFLAGS_OPJ_HAVE_FSEEKO"
@@ -2169,7 +2159,7 @@ URF_DEVS=''
URF_INCLUDE=
URF_DEV=
SURFX_H=
-AC_ARG_WITH([urf], AC_HELP_STRING([--without-urf],
+AC_ARG_WITH([urf], AS_HELP_STRING([--without-urf],
[do not try to include URF support]))
if test x$with_urf != xno; then
@@ -2191,7 +2181,7 @@ AC_SUBST(URF_INCLUDE)
AC_SUBST(URF_DEV)
AC_SUBST(SURFX_H)
-AC_ARG_WITH([cal], AC_HELP_STRING([--without-cal],
+AC_ARG_WITH([cal], AS_HELP_STRING([--without-cal],
[do not try to use the CAL library for acceleration]))
CALSRCDIR=$srcdir/cal
@@ -2228,7 +2218,7 @@ if test x$WITH_CAL != x0; then
])],
[HAVE_SSE4_2="-DHAVE_SSE4_2"], [HAVE_SSE4_2=""])
- #AC_ARG_ENABLE([sse4.2], AC_HELP_STRING([--disable-sse4.2],
+ #AC_ARG_ENABLE([sse4.2], AS_HELP_STRING([--disable-sse4.2],
# [Do not use sse4.2 instrinsics]), [
# if test "x$enable_sse4.2" = xno; then
# HAVE_SSE4_2=""
@@ -2254,7 +2244,7 @@ if test x$WITH_CAL != x0; then
])],
[HAVE_AVX2="-DHAVE_AVX2"], [HAVE_AVX2=""])
- #AC_ARG_ENABLE([sse4.2], AC_HELP_STRING([--disable-sse4.2],
+ #AC_ARG_ENABLE([sse4.2], AS_HELP_STRING([--disable-sse4.2],
# [Do not use sse4.2 instrinsics]), [
# if test "x$enable_sse4.2" = xno; then
# HAVE_SSE4_2=""
@@ -2276,7 +2266,7 @@ if test x$WITH_CAL != x0; then
])],
[HAVE_NEON="-DHAVE_NEON"], [HAVE_NEON=""])
- #AC_ARG_ENABLE([neon], AC_HELP_STRING([--disable-neon],
+ #AC_ARG_ENABLE([neon], AS_HELP_STRING([--disable-neon],
# [Do not use neon instrinsics]), [
# if test "x$enable_neon" = xno; then
# HAVE_NEON=""
@@ -2315,7 +2305,7 @@ AC_SUBST(CAL_AVX2_CFLAGS)
AC_SUBST(CAL_NEON_CFLAGS)
dnl check if we can/should build the gtk loader
-AC_ARG_ENABLE([gtk], AC_HELP_STRING([--disable-gtk],
+AC_ARG_ENABLE([gtk], AS_HELP_STRING([--disable-gtk],
[Do not build the gtk loader]))
SOC_CFLAGS=""
SOC_LIBS=""
@@ -2421,7 +2411,7 @@ AC_SUBST(X_LIBS)
AC_SUBST(XLIBS)
dnl executible name
-AC_ARG_WITH([gs], AC_HELP_STRING([--with-gs=NAME],
+AC_ARG_WITH([gs], AS_HELP_STRING([--with-gs=NAME],
[name of the Ghostscript executible [[gs]]]),
[GS="$with_gs"],[GS='gs'])
AC_SUBST(GS)
@@ -2437,7 +2427,7 @@ PXL_MAK="\$(GLSRCDIR)\$(D)stub.mak"
if test x"$with_pcl" != x"no" ; then
if test -f $srcdir/pcl/pl/pl.mak; then
- AC_ARG_WITH([pcl], AC_HELP_STRING([--with-pcl=NAME],
+ AC_ARG_WITH([pcl], AS_HELP_STRING([--with-pcl=NAME],
[name of the GhostPCL executible (if the source is available, ignored otherwise) [[gpcl6]]]),
[PCL="$with_pcl"],[PCL='gpcl6'])
@@ -2469,7 +2459,7 @@ XPSROMFS_MAK="\$(GLSRCDIR)\$(D)stub.mak"
if test x"$with_xps" != x"no" ; then
if test x"$PCL_TARGET" != x ; then
if test -f $srcdir/xps/xps.mak; then
- AC_ARG_WITH([xps], AC_HELP_STRING([--with-xps=NAME],
+ AC_ARG_WITH([xps], AS_HELP_STRING([--with-xps=NAME],
[name of the GhostXPS executible (if the source is available, ignored otherwise) [[gxps]]]),
[XPS="$with_xps"],[XPS='gxps'])
@@ -2492,7 +2482,7 @@ PDFROMFS_MAK="\$(GLSRCDIR)\$(D)stub.mak"
if test x"$with_pdf" != x"no" ; then
if test -f $srcdir/pdf/pdf.mak; then
- AC_ARG_WITH([pdf], AC_HELP_STRING([--with-pdf=NAME],
+ AC_ARG_WITH([pdf], AS_HELP_STRING([--with-pdf=NAME],
[name of the Ghostpdf executible (if the source is available, ignored otherwise) [[gpdf]]]),
[PDF="$with_pdf"],[PDF='gpdf'])
@@ -2520,7 +2510,7 @@ GPDL_MAK="\$(GLSRCDIR)\$(D)stub.mak"
if test "x$XPS_TARGET" != "x" && test "x$PCL_TARGET" != "x" ; then
if test -f $srcdir/gpdl/gpdl.mak; then
- AC_ARG_WITH([gpdl], AC_HELP_STRING([--with-gpdl=NAME],
+ AC_ARG_WITH([gpdl], AS_HELP_STRING([--with-gpdl=NAME],
[name of the GhostPDL executible (if the source is available, ignored otherwise) [[gpdl]]]),
[GPDL="$with_gpdl"],[GPDL='gpdl'])
@@ -2535,7 +2525,7 @@ AC_SUBST(GPDL_MAK)
dnl do we compile the postscript initialization files into Ghostscript?
COMPILE_INITS="1"
-AC_ARG_ENABLE([compile-inits], AC_HELP_STRING([--disable-compile-inits],
+AC_ARG_ENABLE([compile-inits], AS_HELP_STRING([--disable-compile-inits],
[Do not compile in initialization files]),[
if test "x$enable_compile_inits" = xno; then
COMPILE_INITS="0"
@@ -2631,7 +2621,7 @@ PS_DEVS='psdf psdcmyk psdrgb psdcmyk16 psdrgb16 pdfwrite ps2write eps2write bbox
# device.
#
AC_ARG_WITH([extract-dir],
- AC_HELP_STRING([--with-extract-dir=EXTRACT_DIR],
+ AS_HELP_STRING([--with-extract-dir=EXTRACT_DIR],
[Build with the specified Extract library. By default we build with Extract automatically if <ghostpdl-directory>/extract exists.]
),
[
@@ -2941,7 +2931,7 @@ attr_hidden=
_ldflags=
AC_ARG_ENABLE([hidden-visibility],
- AC_HELP_STRING([--enable-hidden-visibility],
+ AS_HELP_STRING([--enable-hidden-visibility],
[hide all shared library symbols which are not part of its public API]),
[hide_symbols=yes])
@@ -3117,7 +3107,7 @@ AC_SUBST(GPDL_SONAME)
AC_SUBST(GPDL_SONAME_MAJOR)
AC_SUBST(GPDL_SONAME_MAJOR_MINOR)
-AC_ARG_ENABLE([dynamic], AC_HELP_STRING([--enable-dynamic],
+AC_ARG_ENABLE([dynamic], AS_HELP_STRING([--enable-dynamic],
[Enable dynamically loaded drivers]),
[
if test "x$enable_dynamic" != xno; then
@@ -3177,7 +3167,7 @@ AC_SUBST(DLL_EXT)
AC_SUBST(SO_LIB_VERSION_SEPARATOR)
dnl look for default font path...
-AC_ARG_WITH([fontpath], AC_HELP_STRING([--with-fontpath],
+AC_ARG_WITH([fontpath], AS_HELP_STRING([--with-fontpath],
[set font search path for gs]), fontpath="$withval", fontpath="")
dnl Fix "prefix" variable...
@@ -3213,7 +3203,7 @@ fi
AC_SUBST(fontpath)
dnl look for default tessdata...
-AC_ARG_WITH([tessdata], AC_HELP_STRING([--with-tessdata],
+AC_ARG_WITH([tessdata], AS_HELP_STRING([--with-tessdata],
[set tesseract data search path]), tessdata="$withval", tessdata="")
if test "x$tessdata" = "x"; then
@@ -3260,7 +3250,6 @@ dnl of these functions, so the checks are purely informational.
AC_FUNC_FORK
AC_FUNC_MALLOC
AC_FUNC_MEMCMP
-AC_TYPE_SIGNAL
AC_FUNC_STAT
AC_FUNC_VPRINTF
AC_CHECK_FUNCS([bzero dup2 floor gettimeofday memchr memmove memset mkdir mkfifo modf pow putenv rint setenv sqrt strchr strrchr strspn strstr])
@@ -3343,7 +3332,7 @@ ALIGN_TEXT_PROG="\
GS_MEMPTR_ALIGNMENT=
AC_ARG_WITH(memory-alignment,
- [AC_HELP_STRING([--with-memory-alignment],
+ [AS_HELP_STRING([--with-memory-alignment],
[Allows setting minimum alignment for the memory manager (4 or 8 bytes]))],
[GS_MEMPTR_ALIGNMENT=$with_memory_alignment],[GS_MEMPTR_ALIGNMENT=check])
@@ -3411,7 +3400,7 @@ AC_LINK_IFELSE(
])],
[HAVE_BSWAP32="-DHAVE_BSWAP32"], [HAVE_BSWAP32=""])
-AC_ARG_ENABLE([bswap32], AC_HELP_STRING([--disable-bswap32],
+AC_ARG_ENABLE([bswap32], AS_HELP_STRING([--disable-bswap32],
[Do not use bswap32 instrinsic]), [
if test "x$enable_bswap32" = xno; then
HAVE_BSWAP32=""
@@ -3439,7 +3428,7 @@ AC_COMPILE_IFELSE(
])],
[HAVE_BYTESWAP_H="-DHAVE_BYTESWAP_H"], [HAVE_BYTESWAP_H=""])
-AC_ARG_ENABLE([byteswap-h], AC_HELP_STRING([--disable-byteswap-h],
+AC_ARG_ENABLE([byteswap-h], AS_HELP_STRING([--disable-byteswap-h],
[Do not use byteswap.h functions]), [
if test "x$enable_byteswap-h" = xno; then
HAVE_BYTESWAP_H=""
@@ -3458,7 +3447,7 @@ AC_SUBST(HAVE_BYTESWAP_H)
# feature set of GNU make. We still prefer GNU make,
# but......
# --------------------------------------------------
-AC_ARG_WITH([gnu-make], AC_HELP_STRING([--without-gnu-make],
+AC_ARG_WITH([gnu-make], AS_HELP_STRING([--without-gnu-make],
[disable GNU make features]), gnu_make=no)
if test "x$gnu_make" != "xno"; then
@@ -3499,7 +3488,7 @@ case $host in
;;
esac
-AC_ARG_WITH([exe-ext], AC_HELP_STRING([--with-exe-ext=EXT],
+AC_ARG_WITH([exe-ext], AS_HELP_STRING([--with-exe-ext=EXT],
[set the file name executable extension (must include any separator e.g. the period in ".exe")]),
[EXEEXT="$with_exe_ext"])
@@ -3519,7 +3508,7 @@ case $build in
;;
esac
-AC_ARG_WITH([aux-exe-ext], AC_HELP_STRING([--with-aux-exe-ext=EXT],
+AC_ARG_WITH([aux-exe-ext], AS_HELP_STRING([--with-aux-exe-ext=EXT],
[set the file name executable extension for auxiliary binaries (must include any separator e.g. the period in ".exe")]),
[AUXEXEEXT="$with_aux_exe_ext"])
@@ -3558,13 +3547,13 @@ if test $GCC = yes; then
CFLAGS_backup="$CFLAGS"
CFLAGSAUX_backup="$CFLAGSAUX"
CFLAGS="$CFLAGS -fno-strict-aliasing"
- AC_TRY_COMPILE(, [return 0;], [
+ AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[]], [[return 0;]])],[
AC_MSG_RESULT([yes])
CFLAGS_backup="$CFLAGS"
if test x"$host" = x"$build" ; then
CFLAGSAUX_backup="$CFLAGSAUX -fno-strict-aliasing"
fi
- ])
+ ],[])
CFLAGS="$CFLAGS_backup"
CFLAGSAUX="$CFLAGSAUX_backup"
fi
@@ -3709,7 +3698,7 @@ fi
dnl --------------------------------------------------
dnl AUX tool options
dnl --------------------------------------------------
-AC_ARG_ENABLE([mkromfs-quiet], AC_HELP_STRING([--enable-mkromfs-quiet],
+AC_ARG_ENABLE([mkromfs-quiet], AS_HELP_STRING([--enable-mkromfs-quiet],
[Do not emit mkromfs verbose output]), [MKROMFS_FLAGS="-q $MKROMFS_FLAGS"])
AC_SUBST(MKROMFS_FLAGS)