summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorRobin Watts <Robin.Watts@artifex.com>2023-03-01 17:52:00 +0000
committerRobin Watts <Robin.Watts@artifex.com>2023-03-01 19:47:36 +0000
commit23650fc9ed8da17db6f6199cfceb02db5557053e (patch)
treec4596b9e437190d4804db6e5100410503cf15ebd /configure.ac
parenta409d884c2f53b1a2be49597f9bcf9bf9f9bc55f (diff)
downloadghostpdl-23650fc9ed8da17db6f6199cfceb02db5557053e.tar.gz
Tweak configure logic for so pdf export lib.
Attempt to autodetect between linux and darwin. 32bit/64bit/arm options are just gravy. Credit to Chris for the original version of this (that I've probably broken).
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac20
1 files changed, 18 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 2e78ca5ea..e18d2845c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2236,8 +2236,24 @@ if test x$with_so != xno; then
ENABLESO="\$(D_)SO_INCLUDED\$(_D)"
GPDL_SO_TOP_OBJ="\$(GPDLOBJ)/\$(GPDL_SO_TOP_OBJ_FILE)"
# This will do for now, though clearly it's not ideal.
- SO_PDFEXPORT_LIB="\$(SOSRCDIR)/lib/linux/x64/smart-office-lib.a"
-fi
+ case $host in
+ i*86*-linux*|i*86*-gnu)
+ SO_PDFEXPORT_LIB="\$(SOSRCDIR)/lib/linux/x86/smart-office-lib.a"
+ ;;
+ -linux*|-gnu)
+ SO_PDFEXPORT_LIB="\$(SOSRCDIR)/lib/linux/x64/smart-office-lib.a"
+ ;;
+ *arm64*-darwin*)
+ SO_PDFEXPORT_LIB="\$(SOSRCDIR)/lib/macos/arm64/smart-office-lib.a"
+ ;;
+ *i*86-darwin*)
+ SO_PDFEXPORT_LIB="\$(SOSRCDIR)/lib/macos/x86/smart-office-lib.a"
+ ;;
+ *-darwin*)
+ SO_PDFEXPORT_LIB="\$(SOSRCDIR)/lib/macos/x64/smart-office-lib.a"
+ ;;
+ esac
+ fi
fi
AC_SUBST(ENABLESO)