summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorChris Liddell <chris.liddell@artifex.com>2020-09-16 18:49:42 +0100
committerChris Liddell <chris.liddell@artifex.com>2020-10-06 17:05:29 +0100
commit477d315af46d9a7932108135137adc7aebfc77fe (patch)
tree0ac8e5dcdc22a926428f9cf809e14fc68050bac6 /configure.ac
parentc97c4ebb08474e1fbd9a3a6db71da52330f2d67b (diff)
downloadghostpdl-477d315af46d9a7932108135137adc7aebfc77fe.tar.gz
Use pkg-config to get CFLAGS for libidn
We already get the libs, missing the CFLAGS (mainly the -I) was just an omission.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac1
1 files changed, 1 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 758010970..ab71e6f25 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1041,6 +1041,7 @@ if test x$with_libidn != xno; then
if $PKGCONFIG --exists libidn; then
AC_MSG_RESULT(yes)
LIBS="$LIBS `$PKGCONFIG --libs libidn`"
+ CFLAGS="$CFLAGS `$PKGCONFIG --cflags libidn`"
HAVE_LIBIDN=-DHAVE_LIBIDN
else
AC_MSG_RESULT(no)