summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorChris Liddell <chris.liddell@artifex.com>2022-11-24 16:33:47 +0000
committerChris Liddell <chris.liddell@artifex.com>2022-11-25 09:23:19 +0000
commit4c3575346b9c7d394ebc73b4e5fabebadd8877ec (patch)
treeaaf793d3834cc5dca92eef60bd92a68417637503 /configure.ac
parentddccf474ce2a902e5dbabc03526dac3449344317 (diff)
downloadghostpdl-4c3575346b9c7d394ebc73b4e5fabebadd8877ec.tar.gz
Fix a little bitrot in the cross-compiling logic
Removing the option to disable FAPI meant configuring for cross compiling would fail because the option being passed to the sub-call to configure would include an unknown command line option.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index d5c68c4b3..738eb10a9 100644
--- a/configure.ac
+++ b/configure.ac
@@ -138,7 +138,7 @@ if test x"$host" != x"$build" ; then
echo $AUXFLAGS_MAK_LINE07 >> $AUXFLAGS_MAK.in
AC_MSG_NOTICE([Begin recursive call to configure script (for auxiliary tools)])
- "$absolute_source_path/configure" CC="$CCAUX" CFLAGS="$CFLAGSAUX" CPPFLAGS="$CPPFLAGSAUX" LDFLAGS="$LDFLAGSAUX" CCAUX= CFLAGSAUX= CFLAGSAUX= MAKEFILE=$AUXFLAGS_MAK --host=$build --build=$build --enable-auxtools_only --disable-hidden-visibility --with-local-zlib --without-libtiff --disable-contrib --disable-fontconfig --disable-dbus --disable-freetype --disable-fapi --disable-cups --disable-openjpeg --disable-gtk --with-libiconv=no --without-libidn --without-libpaper --without-pdftoraster --without-ijs --without-jbig2dec --without-x --with-drivers=""
+ "$absolute_source_path/configure" CC="$CCAUX" CFLAGS="$CFLAGSAUX" CPPFLAGS="$CPPFLAGSAUX" LDFLAGS="$LDFLAGSAUX" CCAUX= CFLAGSAUX= CFLAGSAUX= MAKEFILE=$AUXFLAGS_MAK --host=$build --build=$build --enable-auxtools_only --disable-hidden-visibility --with-local-zlib --without-libtiff --disable-contrib --disable-fontconfig --disable-dbus --disable-freetype --disable-cups --disable-openjpeg --disable-gtk --with-libiconv=no --without-libidn --without-libpaper --without-pdftoraster --without-ijs --without-jbig2dec --without-x --with-drivers=""
status=$?
cp config.log "$olddir/configaux.log"
if test $status -eq 0 ; then
@@ -2530,7 +2530,7 @@ PDF=
PDF_MAK="\$(GLSRCDIR)\$(D)stub.mak"
PDFROMFS_MAK="\$(GLSRCDIR)\$(D)stub.mak"
-if test x"$with_pdf" != x"no" ; then
+if test x"$with_pdf" != x"no" -a x"$enable_auxtools_only" != x"yes" ; then
if test x"$JBIG2_DECODER" = x""; then
AC_MSG_ERROR([No JBIG2 decoder available, required for PDF support])