summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorChris Liddell <chris.liddell@artifex.com>2022-02-22 17:49:50 +0000
committerChris Liddell <chris.liddell@artifex.com>2022-02-24 15:01:05 +0000
commit54532a89a2f6abdb6142680379c60bef4b94bd16 (patch)
tree0b63aad952ed35dbef606633973f5f134d80f8d2 /configure.ac
parent7d90551531b331e0ea7e14c0776be198211b604d (diff)
downloadghostpdl-54532a89a2f6abdb6142680379c60bef4b94bd16.tar.gz
Fix building with "local" cups sources
Also cups device: Ignore deprecated function warnings Using gcc pragmas
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 3 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index e752bdd0b..86d5eff34 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1763,6 +1763,7 @@ CUPSDATA=""
CUPSVERSION="0"
CUPSPDFTORASTER="0"
CUPS_DIR=""
+LIB_CUPS_DIR="src"
cups_hard_fail=0
@@ -1875,6 +1876,7 @@ if ( test -f $srcdir/cups/gdevcups.c ); then
LCUPSINCLUDE="include \$(GLSRCDIR)/lcups.mak"
LCUPSIINCLUDE="include \$(GLSRCDIR)/lcupsi.mak"
CUPSDEV="cups pwgraster"
+ LIB_CUPS_DIR=$CUPS_DIR
fi
fi
fi
@@ -1889,6 +1891,7 @@ AC_SUBST(CUPSSERVERROOT)
AC_SUBST(CUPSDATA)
AC_SUBST(CUPSINSTALL)
AC_SUBST(CUPS_DIR)
+AC_SUBST(LIB_CUPS_DIR)
AC_SUBST(SHARELCUPS)
AC_SUBST(SHARELCUPSI)