summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorChris Liddell <chris.liddell@artifex.com>2021-09-18 12:36:04 +0100
committerChris Liddell <chris.liddell@artifex.com>2021-09-18 12:39:02 +0100
commit5a9c9fb834fb02ca8116d66a71183b4b994f0e80 (patch)
tree291ab44f257ab94152b05278ba65696269861516 /configure.ac
parent2be6bb5c0cfcbd6ad128cb609744a34a2d5f69fb (diff)
downloadghostpdl-5a9c9fb834fb02ca8116d66a71183b4b994f0e80.tar.gz
Disable gpdf build with no pcl available.
gpdf is based on the gpdl infrastructure, so relies on the pcl/pl/ level APIs. And pcl/pl/ is only available if we include pcl in the available products. So disable gpdf when pcl isn't being built (the same as already done for gpdl and gxps).
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 6 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 421eafc6f..36b51f57a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2496,9 +2496,13 @@ if test x"$with_pdf" != x"no" ; then
if test -f $srcdir/pdf/pdf.mak; then
AC_ARG_WITH([pdf], AS_HELP_STRING([--with-pdf=NAME],
[name of the Ghostpdf executible (if the source is available, ignored otherwise) [[gpdf]]]),
- [PDF="$with_pdf"],[PDF='gpdf'])
- if test -f $srcdir/pcl/pl/pl.mak; then
+ [PDFEXE="$with_pdf"],[PDFEXE='gpdf'])
+
+ if test -f $srcdir/pcl/pl/pl.mak && test x"$PCL_TARGET" != x"" ; then
PDF_TARGET=gpdf
+ PDF=$PDFEXE
+ else
+ PDF=no_gpdf
fi
CFLAGS="-DBUILD_PDF=1 -I$srcdir/pdf $CFLAGS"
GPDF_DEV="\$(PDFOBJDIR)\$(D)pdfi.dev"