summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorRobin Watts <Robin.Watts@artifex.com>2020-10-12 13:19:09 +0100
committerRobin Watts <Robin.Watts@artifex.com>2020-10-13 11:30:41 +0100
commit5af4f31bcda18c6fb7d14501c0a22697a7f49ac0 (patch)
tree5592359aa1cc75d3c277eba3d706ce2b636a831a /configure.ac
parent848077c4f7b8b9131263b483ba90b05e0ee4e9d2 (diff)
downloadghostpdl-5af4f31bcda18c6fb7d14501c0a22697a7f49ac0.tar.gz
Update tesseract traineddata loader with new path search.
First, we look in TESSDATA_PREFIX (if defined). If not found there, we look in ROMFS (in tessdata). If not found there, we look at the configured "tessdata" path (which defaults to ${datadir}/tessdata). (${datadir} defaults to ${prefix}/share on unix, and ${gsrootdir} on windows.) If not found there, we look in the current directory. Update doc/Devices.html (and fix some indexing).
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 10 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 8bd7de3c7..640aca7f0 100644
--- a/configure.ac
+++ b/configure.ac
@@ -3198,6 +3198,16 @@ fi
AC_SUBST(fontpath)
+dnl look for default tessdata...
+AC_ARG_WITH([tessdata], AC_HELP_STRING([--with-tessdata],
+ [set tesseract data search path]), tessdata="$withval", tessdata="")
+
+if test "x$tessdata" = "x"; then
+ tessdata="${datadir}/tessdata"
+fi
+
+AC_SUBST(tessdata)
+
dnl --------------------------------------------------
dnl Check for library functions
dnl --------------------------------------------------