summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorChris Liddell <chris.liddell@artifex.com>2021-06-02 15:32:06 +0100
committerChris Liddell <chris.liddell@artifex.com>2021-06-03 13:19:09 +0100
commit683ad97ab12fed23a44497e17ef64ac89445359b (patch)
treeb79f69dae8beeec5a0969bec11683ccdf86b75a2 /configure.ac
parent7e1687689389b053ec762ac8c41fe79775537256 (diff)
downloadghostpdl-683ad97ab12fed23a44497e17ef64ac89445359b.tar.gz
Disable libdeflate use for libtiff
As part of the Ghostscript/GhostPDL configure script, we also run the libtiff configure. If libdeflate was present, and running Ubuntu 21.04 (or later?) and using our shipped libtiff sources, it would attempt to build with libdeflate support, but not include the library to link to, and cause a build error. We don't need libdeflate support, so disable it explicitly when we call the libtiff configure Also, add an environment variable (GS_TIFF_CONFIGURE_OPTS) to the libtiff configure command line, as an easy "end user" workaround for similar future problems. So doing: ./configure GS_TIFF_CONFIGURE_OPTS="--disable-libdeflate" Would work around the libdeflate issue.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index c4ee5b682..a0d63d2be 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1682,7 +1682,7 @@ if test x"$SHARE_LIBTIFF" = x"0" ; then
if ! test -d "$LIBTIFFCONFDIR" ; then
mkdir "$LIBTIFFCONFDIR"
fi
- cd "$LIBTIFFCONFDIR" && "$absolute_source_path/$LIBTIFFDIR/configure" --disable-jbig --disable-lzma --disable-zstd --disable-webp $SUBCONFIG_OPTS
+ cd "$LIBTIFFCONFDIR" && "$absolute_source_path/$LIBTIFFDIR/configure" $GS_TIFF_CONFIGURE_OPTS --disable-jbig --disable-lzma --disable-zstd --disable-webp --disable-libdeflate $SUBCONFIG_OPTS
status=$?
if test $status -ne 0 ; then
AC_MSG_ERROR([libtiff configure script failed], $status)