summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorChris Liddell <chris.liddell@artifex.com>2021-05-25 10:33:18 +0100
committerChris Liddell <chris.liddell@artifex.com>2021-05-25 13:37:21 +0100
commit6e039df2621d05e9bb158ee22a02378843a6bef2 (patch)
treeb4398d32b861dbf6c165800eeb7bfe206dd384b1 /configure.ac
parentea679515b59a2d28532e674c77d0992a1a58d716 (diff)
downloadghostpdl-6e039df2621d05e9bb158ee22a02378843a6bef2.tar.gz
Bug 703880: Fix lines/line endings in alignment test
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac80
1 files changed, 41 insertions, 39 deletions
diff --git a/configure.ac b/configure.ac
index 9bcfb9d91..c4ee5b682 100644
--- a/configure.ac
+++ b/configure.ac
@@ -3247,48 +3247,50 @@ dnl set memory manager's ptr alignment
dnl --------------------------------------------------
ALIGN_TEXT_PROG_INCS="\
-#include <stdio.h> \
-#include <stdlib.h>"
+#include <stdio.h>
+#include <stdlib.h>
+"
ALIGN_TEXT_PROG="\
- struct altest \
- { \
- char a; \
- int b; \
- long c; \
- long long d; \
- float e; \
- double f; \
- void *g; \
- }; \
- struct altest *a; \
- struct altest d; \
- char *b, *c, *lim; \
- int ret = 0; \
- c = b = malloc(64 * sizeof(struct altest)); \
- lim = b + (64 * sizeof(struct altest)); \
- do \
- { \
- b++; \
- if ((b >= lim) || \
- ((((unsigned int)b) & 4) == 0 && (((unsigned int)b) & 8) != 0)) \
- { \
- break; \
- } \
- } while(1); \
- if (b >= lim) \
- { \
- ret = -1; \
- } \
- else \
- { \
- a = (struct altest *)b; \
- b = a->g; \
- ret = 0; \
- } \
- free(c); \
- exit(ret);"
+ struct altest
+ {
+ char a;
+ int b;
+ long c;
+ long long d;
+ float e;
+ double f;
+ void *g;
+ };
+ struct altest *a;
+ struct altest d;
+ char *b, *c, *lim;
+ int ret = 0;
+ c = b = malloc(64 * sizeof(struct altest));
+ lim = b + (64 * sizeof(struct altest));
+ do
+ {
+ b++;
+ if ((b >= lim) ||
+ ((((unsigned int)b) & 4) == 0 && (((unsigned int)b) & 8) != 0))
+ {
+ break;
+ }
+ } while(1);
+ if (b >= lim)
+ {
+ ret = -1;
+ }
+ else
+ {
+ a = (struct altest *)b;
+ b = a->g;
+ ret = 0;
+ }
+ free(c);
+ exit(ret);
+"
GS_MEMPTR_ALIGNMENT=