summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorRobin Watts <Robin.Watts@artifex.com>2022-09-21 15:56:22 +0100
committerRobin Watts <Robin.Watts@artifex.com>2022-09-27 13:02:21 +0100
commit7c248efec62649cf2f5ae4917e7d7aa648ce81ce (patch)
tree63fe9749d9db0607b4ad6bc0f11655fa68fffd2f /configure.ac
parentebfb46da46e3f2872e4d1136571224a60891f80a (diff)
downloadghostpdl-7c248efec62649cf2f5ae4917e7d7aa648ce81ce.tar.gz
Update GPDL SO target.
Link with an external SO lib, rather than calling out to an exe.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 3 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 33ae7515b..f1e11940b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2188,11 +2188,14 @@ if test x$with_so != xno; then
AC_MSG_RESULT([yes])
ENABLESO="\$(D_)SO_INCLUDED\$(_D)"
GPDL_SO_TOP_OBJ="\$(GPDLOBJ)/\$(GPDL_SO_TOP_OBJ_FILE)"
+ # This will do for now, though clearly it's not ideal.
+ SO_PDFEXPORT_LIB="\$(SOSRCDIR)/lib/linux/x64/smart-office-lib.a"
fi
fi
AC_SUBST(ENABLESO)
AC_SUBST(GPDL_SO_TOP_OBJ)
+AC_SUBST(SO_PDFEXPORT_LIB)
AC_ARG_WITH([cal], AS_HELP_STRING([--without-cal],
[do not try to use the CAL library for acceleration]))