summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorChris Liddell <chris.liddell@artifex.com>2019-11-06 13:29:19 +0000
committerChris Liddell <chris.liddell@artifex.com>2019-11-21 15:28:38 +0000
commit84a1bd8c73d740022877a5911851b8521ecc7458 (patch)
tree7e997b564830cfadba7598a9082e37aa33aed1a8 /configure.ac
parentaaea09a9a0e357b2784536b8476f4ab4fee19b64 (diff)
downloadghostpdl-84a1bd8c73d740022877a5911851b8521ecc7458.tar.gz
Bug 701440: only include libs calling pkg-config for freetype
Only have the -l options, not the -L ones because they confuse genconf
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 9617ab9a8..2c6cd930f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -901,7 +901,7 @@ if test "$enable_fontconfig" != "no"; then
if $PKGCONFIG --exists fontconfig; then
AC_MSG_RESULT(yes)
FONTCONFIG_CFLAGS="$CFLAGS `$PKGCONFIG --cflags fontconfig`"
- FONTCONFIG_LIBS="`$PKGCONFIG --libs fontconfig`"
+ FONTCONFIG_LIBS="`$PKGCONFIG --libs-only-l fontconfig`"
HAVE_FONTCONFIG=-DHAVE_FONTCONFIG
else
AC_MSG_RESULT(no)
@@ -1041,7 +1041,7 @@ if test x"$enable_fapi" != xno; then
if $PKGCONFIG --atleast-version=12.0.6 freetype2; then
AC_MSG_RESULT(yes)
FT_CFLAGS="$CFLAGS `$PKGCONFIG --cflags freetype2`"
- FT_LIBS="`$PKGCONFIG --libs freetype2`"
+ FT_LIBS="`$PKGCONFIG --libs-only-l freetype2`"
FT_BRIDGE=1
SHARE_FT=1
else