summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorRobin Watts <Robin.Watts@artifex.com>2022-09-14 17:39:02 +0100
committerRobin Watts <Robin.Watts@artifex.com>2022-09-19 12:44:06 +0100
commit90fa745b793dc439d59bdab2255867fb7dfb5420 (patch)
tree9e505a53f95d8decd721dba96e52b5d96a2bd617 /configure.ac
parent9e6faf9495945ba6471f693fe01a0f1d1f538edf (diff)
downloadghostpdl-90fa745b793dc439d59bdab2255867fb7dfb5420.tar.gz
Add gpdl support for SmartOffice integration.
No actual SmartOffice code here, just the framework for adding the (private) "SO" interpreter.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac16
1 files changed, 16 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index bb578250c..33ae7515b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2178,6 +2178,22 @@ AC_SUBST(URF_INCLUDE)
AC_SUBST(URF_DEV)
AC_SUBST(SURFX_H)
+ENABLESO=
+AC_ARG_WITH([so], AS_HELP_STRING([--without-smartoffice],
+ [do not try to include SmartOffice support]))
+
+if test x$with_so != xno; then
+ AC_MSG_CHECKING([for SmartOffice support])
+ if test -d $srcdir/so; then
+ AC_MSG_RESULT([yes])
+ ENABLESO="\$(D_)SO_INCLUDED\$(_D)"
+ GPDL_SO_TOP_OBJ="\$(GPDLOBJ)/\$(GPDL_SO_TOP_OBJ_FILE)"
+fi
+fi
+
+AC_SUBST(ENABLESO)
+AC_SUBST(GPDL_SO_TOP_OBJ)
+
AC_ARG_WITH([cal], AS_HELP_STRING([--without-cal],
[do not try to use the CAL library for acceleration]))