summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorChris Liddell <chris.liddell@artifex.com>2022-08-15 11:09:57 +0100
committerChris Liddell <chris.liddell@artifex.com>2022-08-17 08:30:59 +0100
commit9f8ad8cff4ca7d6ce8b772b109b8aa77a84ba97a (patch)
tree2bf05fcdcb665e6beb609587187bacee2a017127 /configure.ac
parent484009742f9107e78cd17582e9455fe57b87b70a (diff)
downloadghostpdl-9f8ad8cff4ca7d6ce8b772b109b8aa77a84ba97a.tar.gz
Check for "make" before checking for GNU make
If left to its defaults, the build system on Unix will assume GNU make, and use GNU make features to speed up the build process. configure would check for GNU make for this reason, but wasn't checking if there was a "make" program available first, leading to a potentiall confusing error message. This checks that a "make" program exists, before trying to check it's GNU make. Secondly, in recognition that some systems (Solaris, for example) have their own make, but often have GNU make available as "gmake", add a "--with-make=" option allowing a user to set a custom name for the make executable to look for and check the version.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 10 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 281e28998..d0e49009e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -560,6 +560,16 @@ dnl feature set of GNU make. We still prefer GNU make,
dnl but......
dnl --------------------------------------------------
+AC_ARG_WITH([make], AS_HELP_STRING([--with-make=@<:@"make" program name@:>@],
+ [If you use a version of make not called "make"]),
+ [MAKE=$with_make], [MAKE=make])
+
+AC_CHECK_PROG(MAKE_EXISTS,[$MAKE],[yes],[no])
+
+if test x"$MAKE_EXISTS" = x"no" ; then
+ AC_MSG_ERROR([Required make program '$MAKE' not found.])
+fi
+
OBJDIR_BSDMAKE_WORKAROUND=obj
SUB_MAKE_OPTION=
ORDER_ONLY=""