summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJulian Smith <julian.smith@artifex.com>2020-11-23 14:09:31 +0000
committerJulian Smith <julian.smith@artifex.com>2021-02-15 13:31:42 +0000
commitb151406bbf22fb9001895f856168166f2ecf7fe2 (patch)
treee03b7f2e52cbf1ebe68718312e064988450499ad /configure.ac
parent833dc8c9ffde58f001308b303c8d7956107633a1 (diff)
downloadghostpdl-b151406bbf22fb9001895f856168166f2ecf7fe2.tar.gz
Added docxwrite device; uses extract library to write docx output.
Summary: This adds a new docxwrite device which generates docx files. Unlike the txtwrite device, we don't output xml for later use by extract-exe or store information about spans in arrays. Instead we call extract functions such as extract_add_char() directly. Code changes: Have moved txtwrite and docxwrite common code into new devices/vector/doc_common.{c,h}. Shared types and functions are currently: txt_glyph_width_t txt_glyph_widths_t txt_glyph_widths() txt_get_unicode() txt_char_widths_to_uts() txt_calculate_text_size() Building: By default we do not build with Extract and there will be no docxwrite device in the final executables. To build with Extract, specify the location of the extract checkout to build and link with. Unix: ./autogen.sh --with-extract-dir=<extract-dir> Windows: Set environmental variable EXTRACT_DIR=<extract-dir> when building, e.g.: EXTRACT_DIR=<extract-dir> devenv.com windows/GhostPDL.sln /Build Debug /Project ghostscript On both Unix and Windows we exit with an error message if the specified location does not exist.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac14
1 files changed, 14 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index fafe37c36..8010bdf67 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2652,6 +2652,20 @@ PCX_DEVS='pcxmono pcxgray pcx16 pcx256 pcx24b pcxcmyk'
PBM_DEVS='pbm pbmraw pgm pgmraw pgnm pgnmraw pnm pnmraw ppm ppmraw pkm pkmraw pksm pksmraw pam pamcmyk4 pamcmyk32 plan plang planm planc plank'
PS_DEVS='psdf psdcmyk psdrgb psdcmyk16 psdrgb16 pdfwrite ps2write eps2write bbox txtwrite inkcov ink_cov psdcmykog fpng pdfimage8 pdfimage24 pdfimage32 PCLm'
+# Handle --with-extract-dir=EXTRACT_DIR - build extract library and docxwrite
+# device.
+#
+AC_ARG_WITH([extract-dir],
+ AC_HELP_STRING([--with-extract-dir=EXTRACT_DIR]),
+ [
+ EXTRACT_DIR="$withval"
+ AS_IF([test ! -e $EXTRACT_DIR], AC_MSG_ERROR([EXTRACT_DIR does not exist: $EXTRACT_DIR]))
+ PS_DEVS="$PS_DEVS docxwrite"
+ ]
+)
+
+AC_SUBST(EXTRACT_DIR)
+
# the "display" device isn't an ideal fit in the list below, but it saves adding a "list" for just that one entry
MISC_FDEVS='ccr cif inferno mgr4 mgr8 mgrgray2 mgrgray4 mgrgray8 mgrmono miff24 plan9bm bit bitrgb bitrgbtags bitcmyk devicen spotcmyk xcf plib plibg plibm plibc plibk display'