summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMichael Vhrel <michael.vrhel@artifex.com>2021-06-14 16:54:23 -0700
committerRobin Watts <Robin.Watts@artifex.com>2022-01-11 19:16:46 +0000
commitb7d54abe97fb3e2d15cd464d540c3da631a26b38 (patch)
tree8242f136185b08fcc38709e9c00c487612afa4d3 /configure.ac
parent9062e2cf51bb46618485abac9d20b2da4651fd2d (diff)
downloadghostpdl-b7d54abe97fb3e2d15cd464d540c3da631a26b38.tar.gz
Add psdcmyktags and psdcmyktags16 devices
Add example tags devn devices, both 8 and 16 bit. The tags plane is always placed as the last plane in the data (i.e it follows any spots that get added). Changes were made to remove tags conditionals in the planar memory device code, since it really should not care what the extra planes are used for and it should not add components to the device based upon the tags support. The target device should handle any of this sort of setup. There were also some changes needed in the pdf14 code, as the tags information was not getting properly communicated when we had knockout objects and devn colors. Also, fix various whitespace issues.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index f26d3ad0b..0ea1f6a7d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2608,7 +2608,7 @@ JPEG_DEVS='jpeg jpeggray jpegcmyk'
PCX_DEVS='pcxmono pcxgray pcx16 pcx256 pcx24b pcxcmyk'
PBM_DEVS='pbm pbmraw pgm pgmraw pgnm pgnmraw pnm pnmraw ppm ppmraw pkm pkmraw pksm pksmraw pam pamcmyk4 pamcmyk32 plan plang planm planc plank'
-PS_DEVS='psdf psdcmyk psdrgb psdcmyk16 psdrgb16 pdfwrite ps2write eps2write bbox txtwrite inkcov ink_cov psdcmykog fpng pdfimage8 pdfimage24 pdfimage32 PCLm'
+PS_DEVS='psdf psdcmyk psdrgb psdcmyk16 psdrgb16 psdcmyktags psdcmyktags16 pdfwrite ps2write eps2write bbox txtwrite inkcov ink_cov psdcmykog fpng pdfimage8 pdfimage24 pdfimage32 PCLm'
# Handle --with-extract-dir=EXTRACT_DIR - build extract library and docxwrite
# device.